DNS resolve issue

Hello,

I run a cross a very strange issue, running a CentOS 6.2 (Virtualmin) and some servers such as BIND, Apache, Mail etc… but today I noticed that DNS resolve is not working anymore…

This server used its own local ip address for DNS resolve: 127.0.0.1 and this worked 6-7 months without any problems, but today it suddenly stopped.

Now I cannot ping external domains from this server but I can ping the external ip addresses.
however DNS (BIND) server service is up and running and this server hosts around 20 domain names
and this is working just fine, but server it self cannot ping external domains for some reasons because the resolve is not working when this server is using its own local address 127.0.0.1

Any good idea ??

Thank You

Amel

Did you try “re-check” configuration?

yes I did it, and no errors found… I also run an check for BIND and no errors found…

Can you paste the contents of your files /etc/networking/interfaces and /etc/resolv.conf?

Also, what result do you get for nslookup example.com and dig example.com?

Does /var/log/syslog log any BIND errors when you try those?

Hello, thank You for reply, sorry for delayed answer, I was very busy.

nano /etc/resolv.conf

nameserver 127.0.0.1
nameserver 10.48.24.19

nano /etc/networking/interfaces

is empty…

/var/log/syslog

no errors here, BIND is working just fine…

nslookup is also working just fine, when I run nslookup from this server which is running dns:

nslookup
server 127.0.0.1

than I ask it for a domain and I receive it no problems at all…

But this server cannot use it`s own 127.0.0.1 for resolve, very wired…

We will try to restore backup files since this is an Virtual Vmware machine…

Thank You again !!

Amel

PS:

nameserver 10.48.24.19 is the ip address of this DNS server, and I just added both 127.0.0.1 and 10.48.24.19 … it is the same “local” server…

not sure what the problem was but we have restored the snapshot and it is working fine now… will follow it now…