DNS Report Shows Error (MX Records & SOA Serial)

Hi there,
Recently google webmaster tools pop a DNS error so i check my DNS report and found this error

SOA Serial and MX Records

Little help here please.


Are things working for you now?

If so, I’d suggest just keeping things as they are, there isn’t a problem with either of those, unless something isn’t working.

The SOA number isn’t an issue I’d be concerned about.

The MX record – that may indicate that either your DNS is hosted at a third party, and no MX record was added – or that it’s hosted on your Virtualmin server, and the default MX record was deleted. If the latter is the case, you can re-add that in Server Configuration -> DNS Records.


HI hi,
Well after my last virtual host error things are better never had any problem add 3rd domain as well :slight_smile:

actually in my Google Webmaster Tools indicate DNS error. after creating my virtual server all i did was go to my Domain Manager and add A Records with my server IP nothing also i let my domain manager use there default NS1 and NS2 that’s all.

How can i add in Server Configuration -> DNS Records. what should i put there :slight_smile: i have no idea about MX Records.

Thank you andreychek


Well, let’s start here – is your Virtualmin server hosting your DNS? Or is DNS being hosted at a third party?

It sounds like you’re saying you went into a Domain Manager to add an ‘A’ record – which makes it sound like you’re hosting DNS at a third party.

If that’s the case – you’d have to add the MX record using that same Domain Manager.


Hi andreychek
Yes you are correct, i did like this bcuz this is the only way i knew :slight_smile: if i wan’t to host my DNS with virtualmin like you mention and put MX record how should i do? it is easy for me to manage everything win virtualmin than to use 3rd party service.

Thank you again :slight_smile:


Hosting DNS at a third party is no problem, you simply need to add an MX record (to get rid of the warning you’re seeing – you don’t actually have to have an MX record).

Details for how to use your Virtualmin server as a nameserver are available here in the section titled “How do I setup nameservers for my server”:


If NS1.DOMAIN.COM and NS2.DOMAIN.COM are both on the same server, I would not set “Additional manually configured nameservers”. There’s no real reason to set them both if they’re on the same server.

The value of “Master DNS server hostname” does not technically matter, so long as it resolves to your server – however, you’d probably get rid of a yellow warning box somewhere by setting that to “NS1.DOMAIN.COM”.


I did go to domain registarr and add my new name server as NS1.DOMAIN.COM NS2.DOMAIN.COM and login to my virtualmin and Server Configuration - DNS Records and add 2 of my NS with my server IP
last step, i want to make sure what i have to put to “Additional manually configured nameservers” and “Master DNS server hostname”

Is it my NS1.DOMAIN.COM i’m sorry if this is dumb question to ask still learning :slight_smile:

I guess something went wrong i’m screwed… my site is not coming :slight_smile: grrr…

kindly check these images
DNS Records

Server Configuration

Finally DNS Check info

What should i do to the A record that i entered in my domain manager Leave it as it is?

Sorry for messing things up… i need your support

I dont know how but i went and change these value http://i47.tinypic.com/14e3muv.jpg
also there was only NS1 records and i created NS2 records in BIND DNS Server

and no more red error result only few yellow errors http://i48.tinypic.com/34qjvkm.jpg

I have no idea how it happen but i want to know is this the correct way?


That all looks perfectly normal!

The warnings you’re seeing are all expected for a single nameserver such as what you’re running there.

Those settings should all work just fine for your server there.

Is your site working now though?


Yeah finally i did it… haha yes my site working fine now for me. ok so i will ignore those errors. just wanna thank you again for not letting me down… :slight_smile:

Thank you andreychek