DNS problems

Hi there,

I am trying to set up a new Virtualmin GPL server and am having some problems with the DNS.

There are 3 domains pointing at the server (plus a couple aliases), some have subdomains. There are 10 IP addresses and each domain and subdomain has to have its own IP. I have created servers for the domains and created sub servers for the subdomains.

There seems to be a problem with the IP address that gets entered into the top level domains DNS hosts file. I have had to change the IP addresses because when the server was first put up it didn’t have these 10 IP addresses until they moved it out separate from the other one.

So I am not sure exactly which files you need or what I should do or if this is a known issue or what to do now. I would pay for someone to fix this if thats what it takes. Just let me know.

Ryan

Did you add the IP’s in the networking module and make virtual ifaces
Did you add the IP’s to the shared list under Addresses and Networking
Did you create the sub servers as top level domains
Did you assign each domain its own IP address then

Hi, thank you for answering! Eventhough I didn’t provide much info. I just am not really sure what the problem is but I think it has something to do with the DNS since its dealing with the IPs.

Did you add the IP’s in the networking module and make virtual ifaces

I didn’t do this myself. The host added the IP addresses to the server and they show up in that list. I don’t know if this matters but some say eth0:0 Ethernet (Virtualmin) and the last 2 IPs say Ethernet (Virtual) instead.

Did you add the IP’s to the shared list under Addresses and Networking

Yes I did. The first one is the default one, the rest are in the box on a line each and “Allocate a new shared IP address” is unchecked.

Did you create the sub servers as top level domains

They are subdomains. Except where they are the domain alias which 2 of them have some of. Could this be the problem? I created sub-servers as subdomains in Create Virtual Server > Sub-server. Maybe I have to convert them to parent servers or change them somehow to a top level server.

Did you assign each domain its own IP address then

Yes, after they added the IPs to the system and moved it out and give it 10 all new addresses. Each domain and subdomain is supposed to have its own IP so I went to Server Configuration > Change IP Address.

I was for awhile thinking it was something I did wrong but I can’t figure out what. It also seems it is sometimes randomly showing the wrong domain and putting in * as all the virtual host names. I found some documentation ( http://www.virtualmin.com/documentation/web/troubleshooting##the_wrong_site_shows_up ) about the wrong site showing but I couldn’t seem to figure out what the problem is since everything looked right to me, it just wasn’t working right.

so we probably need to see the virtualhost containers of the domains in question.

in the apache config file at the bottom are those containers starting with:
< VirtualHost ip.goes.here.xx:80 >
every container should then have its own ip, if there is a * then you would have to change that.

Thanks ronald! But guess what, they purchased the Pro version =) Hopefully things will only get better from here.

I actually may have solved the problem by moving out the domains I created as sub servers to top level parent domains. This moved their DNS entries to their own hosts files and I changed the host on the system to a subdomain of the domain and use that as the primary name server as well as the apache host. I also updated the system since there seems to have been a ton of updates. And I rebooted it. Everything looks ok now… I think anyway. intodns isn’t giving any errors except for the nameservers being on the same subnet and single point of failure and whatnot.

Now for seeing how to go about upgrading to Pro. I have Pro on my own server installed from scratch as Pro. This is a client server and was installed from scratch as GPL. I trust you guys to have made this an easy process like everything else =)

When you create the subserver as a top level domain , it will get its own zone file.
However there is an option in the template “Add sub-domain DNS records to parent domain?” and set it to no. That should do the trick also (for new domains) but Im not sure it is in the GPL version.

Thanks so much ronald. Great support as always =) You guys amaze me.

FYI, the GPL version does have those options by the looks of it:

System Settings > Server Templates > Default Settings > Edit template section: “BIND DNS domain” > Set “Add sub-domain DNS records to parent domain?” to No

System Settings > Server Templates > Default Settings For Sub-Servers > Edit template section: “BIND DNS domain” > Set “Add sub-domain DNS records to parent domain?” to No

And it looks like those steps are the same for GPL and Pro. Not sure what the default settings should be but I think they might be set to No already. Not sure if there are situations where that would change or not.

PS: this is the same guy, just was logged in with their Pro account woops =)