DNS Problem Please help

I had webmin than I have installed virtualmin gpl to manage my other domain names.

I was just using one domain number under webmin. Than I installed virtualmin and added my other domain name

I assign that domain name with one of my empty IP address which is

seems like everything is working but I am not sure what name servers should I put in my domain name servers? Because I don’t see anything on NS records except my domain name and its IP address there is nothing like ns1 or ns2

I am not sure what name servers should I use? can you please help me thank you

anybody please?

DNS is a complex topic, I highly recommend reading up on it – I enjoyed O’Reilly’s “DNS and BIND”, but there’s lots of other resources regarding that too.

However, what nameservers did you use for your first domain? You may be able to re-use those on your second domain.

Andrey thank you for your response here is what I did:

so for my first domain name I use IP addreses: ns1.mydomain.com ns2.mydomain.com

than I create this new domain name under virtualmin, IP address: mydomain2.com

so that created new folder for it and when I go to that IP address I see centos default page so it looks like everything is working just fine.

But in my dns settings I dont see no ns1 or ns2 records so I tried my first domain name settings that didnt work. (ns1.mydomain.com)

than when I tried to add my second domain name address like ns1.mydomain2.com domain manager didnt recognize that.

Your nameservers are ns1.mydomain.com and ns2.mydomain.com – those are all setup correctly (I verified that in the whois database and tested the associated IP addresses).

So for your new domain, mydomain2.com, you want to continue using your server’s nameservers – ns1.mydomain.com and ns2.mydomain.com.

If that doesn’t work for some reason, then that’s the problem – you’ll need to look into why things don’t work with those settings.

I’d go into Services -> “DNS Domain” for domain2.com, and make sure the IP addresses listed there are all correct.

I am not sure what is the problem but I see

move to view option which I have external and localhost_resolver

is that anything to do with this?

when I whois my second domain name I see nameservers has been changed to my domain 1 but not the IP address for some reasons? any ideas why?

thank you

is this anything to do with webmin servers index? thank you

anybody please
thank you!