DNS issues

I was having problems reaching my site hosted on a virtualmin virtual server. It is the only site I have hosted on the server right now (I am just learning my way around virtualmin and VPSs in general) and I can access it via IP address but not via the domain name. Running whois returned the correct nameservers so I then ran host mysite.com ns1.mynameserver.com and received “connection timed out; no servers could be reached.” I then added my ip address manually to named.conf and ran host mysite.com ns1.mynameserver.com again which now yields the correct IP. The only problem is my site is still unreachable via the domain name (I get “server not found”. I setup all the DNS stuff more than 24hrs ago with the exception of adding my IP to the named.conf file. My question is shouldn’t my domain name resolve to the site now that host mysite.com ns1.mynameserver.com returns the correct IP? Any idea as to what I should do next? Also, why did I have to add my IP manually to named.conf? Did I miss something in the virtualmin setup or (more likely) screw up some setting that I am not aware of? I did set virtualmin to listen locally only so as to access it via an ssh tunnel, could this have lead to an alteration of the named.conf file?

I appreciate any assistance and beg your indulgence of a rank amateur. I am sure this is just the first of many stupid questions.


Yeah, you shouldn’t have to manually add anything to the BIND config.

If you go into Edit Virtual Server -> Enabled Features, is the DNS Domain feature enabled?

Also, if you go to intodns.com, and put your domain name into there, does it notice any errors? Intodns can be good for troubleshooting DNS issues.


Thanks for the reply Eric!

The DNS Domain feature is enabled under the virtual server.

Thanks for the intodns.com suggestion! There are a few errors, all going back to the nameservers not responding. The correct IPs are listed.

I should note that it looks like all the DNS records appear to be in order.

I really appreciate the help.

Thanks to Eric for his efforts. I finally got it figured out after seeing this thread https://www.virtualmin.com/node/26311.

Apparently my named.conf file was just completely setup for local access only and I needed to change allow-query to { any; }.

The DNS configuration doesn’t seem to be as automatic as I anticipated it would be. Do I have a screwed up setting somewhere or is this just the way it is supposed to work?


It sounds like it’s just an issue with a default on the BIND setup you had… now that you made that tweak, I wouldn’t be concerned, you should be good to go!

And if you do happen to run into any issues, just let us know and we can figure it out :slight_smile:

Have a good one!