dns is using wrong IP

On my server, I’m using virtualmin, and the server is hooked up to my router, so it has it’s own private IP. virtualmin is using this ip instead of the public IP, which I know it can see, since it shows it on the dynamic domain updating. I need the DNS server tu use this (dynamic) external IP instead of the private ip, which is is currently using. How would I do this?

oops, double posted it. sorry!

System Settings -> Module Config -> Server Settings -> Default IP address for DNS records (you put public IP there)

that won’t work, since I have a dynamic IP and I don’t want to go there every day and change the IP.