dns error when tryting to get to https: mydomain.tld:10000

I can get to the webmin panel fine from the linux box, but not from my laptop, it produces a DNS error?
Any clues what I could have done to do this on Suse 10.0 webversion 1.262 virtualmin 3.08

It has something to do with the suse 10.0 firewall, when I turn it off I can get through, but with it on, I can’t.

I’ve been trying to figure out how to convince SuSEfirewall2 to pick up the current iptables rules from the command line…so far without luck. On a lot of Linux systems, one can just run iptables-save and it puts the rules into a standard save file. But SuSEfirewall2 has its own configuration file and the only way to insert rules is using the SuSEfirewall2 command. Foolishness, and it means I can’t have one standard way of setting up rules across all Linux systems.

Nonetheless, it will be added to the installer very soon–I’ve been working on it this weekend, even.

But in the meantime, you can use yast to add rules for the following services and ports:

POP3/POP3S
IMAP/IMAPS
10000
20000
HTTP/HTTPS
SMTP
DNS
SSH

That’ll probably cover most use cases.

Click the Advanced button on the firewall page. It’ll allow you to add arbitrary ports.

Okay, I see how in the suse firewall, I can add HTTP, HTTPS, DNS POP3 etc, but howwww do you enter anything not on the list like 10000, or 20000 or for that matter fpt on port 21?