DNS Confusing

Hi there everyone,

About a couple of days ago i bought a new vps, off course i have insalled virualmin and everything is working fine, but i found one problem that i can’t get fixed by myself.

On virtualmin we can build our own dns server but what now if i wanna use the dns server of my vps hoster, how can i setup this in virtualmin?, i got a file from my hoster that say that i need to change /etc/named.conf with the follow information.

allow-transfer {46.249.37.254;};

notify yes;

also-notify {46.249.37.254;};

allow-recursion { 127.0.0.1; };

listen-on-v6{any;};

notify-source yourserverip;

transfer-source yourserverip;

But if i open this file i don’t see any of those lines.
What most i do now to change this and let this work.

I hope there is some one that can help me.
For now i wish everyone a nice Christmas don’t eat to much guys :wink:

These lines indeed wouldn’t exist by default; you can just add them in the “options” block of /etc/bind/named.conf.options.

Be aware though that these lines that your hoster sent you suggest that the nameserver at your hoster is used as a slave server, and your Virtualmin is going to be the master. The lines allow what I suppose is the IP of your hoster’s DNS server to do zone transfers from your Virtualmin.

Actually you don’t need to manually add these lines. Virtualmin has a built-in function to define additional slave DNS servers (in the server template, section BIND DNS Zone), which causes the proper allow-transfer lines to be generated for each of your zones.

Thanks for your response Locutus but i got a couple questions more about this topic, as in your answer you tell me that i can do this in bind but how. I have find bind but where do i need to enter this information, is that here: Default zone settings and then in the field Allow transfers from… Or am i wrong.

Best would be to log in to your server via SSH and edit the config file I named directly. Then restart BIND using service bind9 restart.