Dns configuration not automatic

Hello,

I just did a first install of Virtuamin and I see that it does not automaticall configure dns and bind9 on the server the way VestaCP and CentOs Web Panel do.

Is automatic configuration available with a paid license?

Thanks

CNedas.

Hello @cnedas and welcome to the community.

Virtualmin is not a VestaCP or CWP clone, hence it does not work the way those panels do. Virtualmin GPL does configure DNS automatically.

Do you need information or have specific questions about installing Virtualmin or prepping your domain to work with Virtualmin’s DNS?

Hello,

I am at the post-installation wizard and I get this warning message:

Warning! Primary nameserver cannot be resolved from the rest of the Internet : Unknown response :

That is why I say it is not as automatic as other panel options.

Yes, I see what you mean: the current version of Virtualmin makes you specify the nameservers. A future version of Virtualmin will use AI or some other method to divine the nameservers that you want to use and automatically enter these in the post-installation wizard.

Since you have a perfectly sound reason and have employed irrefutable logic to arrive at your conclusion that Virtualmin is ‘not as automatic as other panel’ and since you have not responded to my offer to ask questions or seek information, I wish you good day.

Anyone else willing to provide input without getting hurt?

Have you registered the nameservers with the registrar holding the domain with which they are associated?

Richard

Are you willing to listen to the advice you’re getting and take advantage of it?

Virtualmin works in a way that when you create a virtualserver it checks to see if that domain actually exists. Yours does not, hence the error. That doesn’t mean it isn’t “automatic”. That means you don’t own the domain you’re trying to register or that domain does not exist.

What you’ll need to do is name your virtual server a domain name that you own or a variation thereof.

For instance, one of the domains I own is exposingwot.com. So when I set up my system, it was named vpn.exposingwot.com. I own that domain so it treats it like a subdomain and everything works automatically out of the box.

What I can’t do is name it thebigbomb. I don’t own that domain and that domain may not even exist, so the software can’t reconcile it with the internet so you get the error.

It’s automatic if you’re naming your servers names that actually exist. The other systems allow you to name it anything you want without it reconciling with the real world.

1 Like

Hello,

Yes, I have registered the nameservers with the registra.

As I explained before I have tested with both VestaCP and CentOS CWP and they both configure DND out of the box after configuring name servers at my registra; however, that did not happen with Virtualmin and I get the warning message I posted.

I have actually manged to add a virtual server to virtualmin with a second domain that also has nameserver with same IP at registra, and that new domain seems to be working fine becaue I was able to use FTP, but I don’t know why the post-installation wizard rejected my primary domain and nameservers.

Any other suggestions?

Hello,

As I just mentioned I was able to add another virtual server using a a second domain and seems to work fine as I was able to login via FTP, SSL also works, but I have problem setting up email with Outlook. I gues I will figure that out with time.

However, I still don’t know why the pre install wizard did not accept my main/primary domain. As you said, I have a domain: mydomain.com which I own and the name server I was trying to add with the install wizard was ns1.mydomain.com but it wasn’t accepted. But, again, FTP works, I still have to test email to verify if DNS was configured correctly.

Thanks for the help.

Now I’m even more confused. You don’t set up a nameserver with the install wizard. What exactly were you doing?

Giving a step by step of what you did is what people want. This is the third different statement you’ve made so far, so that’s why people are bowing out and not helping you.

Edit to add: if you’re trying to add name servers, read here:

DNS Frequently Asked Questions | Virtualmin’.

1 Like

Hello Gomez,

Since a picture is worth a thousand words please take a look at the image attached.

If the subsequent one worked, I really wouldn’t worry about it. The worldwide DNS system is rickety enough that it’s a miracle that it works as well as it does. I’d be inclined to dismiss a one-time, non-reproducible failure as an Internet fart and forget about it.

Richard

Your picture is worthless because it doesn’t entail anything you’ve done over the long haul.

For example: that picture doesn’t apply at all to creating a nameserver on an established system.

So now, I’m out as well. If you’re going to continue to play kids games and “guess what I screwed up” games, you’re on your own.

Good luck. You’re going to need it.

I don’t get it…what do you mean by an established system?

On the image I attached Virtualmin is asking me to provide a primary nameserver. I think I did that and then I got the warning:

“Primary nameserver cannot be resolved on this system”.

That is why I said at first that Virtualmin seems not be as automatic as other panels…or what should I write there?

FYI. I don’t believe in luck or god for that matter. :slight_smile:

@cnedas,

Heads up, I sent you a private message – just in case you didn’t notice. Always happy to help.

Best Regards,
Peter Knowles | TPN Solutions

I will answer since you have asked: you should have started your interaction with something like “I don’t know / don’t understand which domain name I should specify for my primary nameserver. When I enter simple1944.redacted.tld in the Post-Install Wizard, I get such-and-such an error”. This would have been an accurate and informative statement, where you take responsibility for your newbie ignorance and inexperience with Virtualmin and offer the Virtualmin community factual information to which it could respond in a meaningful way.

Instead, your initial message and subsequent messages shift the blame of your ignorance, inexperience and the unreasonable expectations that you have of Virtualmin to the functionality and the feature-set Virtualmin offers. I quote your comment “…I see that it does not automaticall configure dns and bind9 on the server…” and “…That is why I say it is not as automatic as other panel…”. Furthermore, you have elected to post your messages under the topic that you have captioned - " Dns configuration not automatic" - and that’s just not true! How dare you, @cnedas, run down in this cavalier manner Virtualmin, a tested and proven open source system which is used by thousands of newbies such as yourself every year and tens of thousands of legacy users for more than a decade?

So many newbies manage to successfully install Virtualmin with only the instructions provided in the official documentation; and with help which is freely offered via the forums by the community. If you have failed in this instance then that’s on you. It’s your fault, not Virtualmin’s. Ask for help from the Virtualmin community keeping this foremost in mind and all will be well.

So, it seems that you were hurt or offended because I said that Virtualmin seems not be as automatic as other panels?

I am focusing on my nameserver issue and not being able to configure Virtualmin correclty, you are focunsing on me because you feel I insulted your favorite panel.

As far as I know these support forums were invented to get help from the community, so I don’t understand why you had to ask if I needed help in the first place.

And the fact the you and Gomez keep calling me adjectives instead of just asking me to be clearer with my messages says much about you.

Peace but no love for you.

No control panel can “automatically” set this up. It requires delegation, or glue records, to be setup at your registrar.

This is simply a misunderstanding of what this screen is about and what the warning means.

If you aren’t at the point where you have delegated authority for DNS to your Virtualmin server (and optionally additional name servers that are managed by Virtualmin via Webmin’s slave DNS feature), you just check “Skip check for resolvability”. That’s what you do here if your Virtualmin server isn’t already configured as a name server for the domain. (And, by “configured” here, I again mean at your registrar…a thing we can’t control and no control panel can control, AFAIK. Though I guess some registrars have APIs and could maybe be convinced to be automated somewhat.)

1 Like

Hello Joe,

That is the strange thing. Glue records had already been setup.

I really thought others in the community would understand that since I mentioned that I was able to configure my server with VestaCP and Centos CWP that would mean glue records had alredy been configured correctly because there is no way a website would load unless you setup glue records or nameservers at your registra.

I did what you mention “Skip check for resolvability” and decided to add a virtual server which worked just fine, but I was affraid that if the initial pre config wizard was not completely configured, I would see errors in the future.

So far only minor issues with PHP configuration and having a hard time using procmailrc

Thanks for input!

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.