DNS-based validation failed : Only the offical Let’s Encrypt client supports DNS-based validation

Hi, Didn’t find answer here and all other topics are closed so creating new topic for others! When you want to add lets encrypt certificate for subdomain and using different DNS service than Virtualmin, remember to add correct CNAME entry before requesting certificate. Remember to use “Domain names listed here” to enter correct domains when requesting.

Here is example from net how to do it:

To Enable lets encrypt SSL on Subdomain Add these DNS records before requesting Let’s Encrypt

For example to setup SSL for test.domain.com

  1. A record for test —> IP address or CName Record for test —> domain.com
  2. CNAME record for www.test —> test.domain.com

Note, these settings are for cloudflare, might be a little different for your provider. If you dont want www.test.domain.comjust use request certificate for test.domain.com and it should work just fine.

Take care!

hello, i noticed this last days, and happens to me too because i have proxy and i’ve set down my proxy and renew, then press in renew, but with 10+ domains it’s not viable

i test and works it:
install cerbot package

apt-get install certbot

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.