DNS and SMTP

I am new to Virtualmin, but have gotten it installed and running fairly well on CentOS 5. I did have the problem with Dovecot after an upgrade, but I did manage to find a solution. It is still working.

I have 2 questions. I have searched the forums for answers, but either haven’t found one that fits my situation, don’t want to make mass changes to the format of logins, or don’t understand the solutions.

I am wanting to allow users to send email through the server. Now, I guess I just presumed that the server would be setup, since I used the install script, to allow this to happen. When I try and sent email through the server, Thunderbird says that it cannot find smtp.myserver.com. So, is this not setup to work, or is this a DNS issue?

This leads to my other question.

DNS doesn’t seem to work. I use freedns.afraid.org for my dns. I was using that prior to purchasing and install Virtualmin. I had hoped that using Virtualmin would allow me to do my own dns. I created some virtual servers and moved some domains to this server. I then updated the dns at freedns to point to the new server IP. Everything worked fine. I then decided that I would test dns by removing 1 domain from freedns and updating the nameserver at my registrar. I tried to point the domain to ns.myserver.com and I was met with Error in Response from Server. So I had to switch back.

Now, I may not have something set right, but since I don’t know I thought I should for help.

What have I done wrong, what can I fix, what else do I need to do?

If you need more details, please let me know and I will do my best.

Thanks for the help.