DMARC - missing 'mailto:' from DNS Record

The DMARC Record generated when enabling DMARC in ‘Virtualmin - Server Configuration - DNS Options’ is missing ‘mailto:’

Generated record is something like “v=DMARC1; pct=100; ruf=postmaster@example.com; rua=postmaster@example.com; p=reject”

When it should be “v=DMARC1; pct=100; ruf=**mailto:**postmaster@example.com; rua=**mailto:**postmaster@example.com; p=reject”

This was not the case not too long ago.

It is possible to manually fix this in ‘Virtualmin - Server Configuration - DNS Records’ but it breaks once DNS Option are saved again

Experienced on
Operating system Ubuntu Linux 14.04
Webmin version 1.881
Virtualmin version 6.03.gpl

as well as

Operating system Ubuntu Linux 16.04
Webmin version 1.883
Virtualmin version 6.03.gpl

Same here.
In server template:
“Reporting URI for forensic reports: mailto:postmaster@domain” and “Reporting URI for aggregate reports: mailto:postmaster@domain” is selected but the generated DNS record is missing “mailto:” in both options.

Debian 9, Webmin 1.881, Virtualmin 6.03 gpl

Same here. created a new domain and the dmarc entry is wrong! This has worked before.

6.03 Pro
1.741

I usually create my own DMARC and SPF zone records using https://mxtoolbox.com

You also cant go wrong with these…

https://www.spfwizard.net/

https://dmarc.org/resources/deployment-tools/

By far the most reliable way to do it!

That’s not the issue here. I know how to create SPF and DMARC and do it manually. The issue is that virtualmin is not creating them correctly when you add a new virtual server. This needs to be fixed ASAP. The other issue is that if you change something and the DNS get’s re-created it will screw it up again. Not acceptable.

If i have to do it manually then why would i need Virtualmin in the first place.