DKIM: wrong selector used (Solved, but why did it happen?)

This is the situation.
Old server: Webmin 1.740 Virtualmin 4.16 GPL. Debian 7 (Wheezy)

On this server I used DKIM selector 2015

New server: Webmin 1.741 Virtualmin 6.03 GPL Debian 8 (Jessie)

The new server I created some time ago. I am not sure I set up DKIM at installation time. But I assume I did.

Then I migrated a domain from the old server to the new server. In the mail settings for this domain the DKIM selector was set to 2015. Still, any mail which was sent, used s=2017.

For the life of it I could not find any setting in Virtualmin which determined this s=2015.

Then, the contents of /etc/dkim-keytable:

default %:2017:/etc/dkim.key

I changed this to:

default %:2015:/etc/dkim.key

And everything was fine again, that is s=2015 was used.

Is this my error because I had created a DKIM record with s=2017 once? Should not this have been overwritten by restoring the backup? Was changing /etc/dkim-keytable the recommended way? Or had I better created a complete new DKIM record and updated my DNS? Was there a setting in Virtualmin to correct this?

If I was stupid, at least this post should help out someone else.

jlinkels