dkim stops working! solved


me stupid, it’s dkim not domain key signature which will be enabled via virtualmin. well well

otherwise, to solve dkim conf missmatch issues, best to --purge with apt-get dkim (similar like install), but remove all configs and fresh reinstall

hi there

i recently realised, that my e-mails are not signed. i have a external dns server with the public key:


a check in my headers mail told me that they are not signed:

DomainKeys check details:

Result: neutral (message not signed)

virtualmin shows that dkim is enabled an signing the messages. i thought that the service is not running, deactivated the signing and tried to reactivate it:

Signing of outgoing mail enabled? yes / no

i can press yes, and everything goes through without warning, but at the end signing is again turned off. how can i enable it?

i have installed dkim via apt, as mentioned and it’s the newest version, what could this be? anything to do with a recent signing via ssl certificate?

it was working, maybe until ssl certificate integration recently, and now i have a big huge problem, as lots of mail will fail to be delivered.