Dkim Key not getting replaced

OS type and version Ubuntu 20.04
Virtualmin version 6.17-3

Hello all,

I have generated a new Dkim key for my servers, but the email signature key is still the old one. The key length is set to 1024. I have the correct DNS entry, but in the email signature I can see that the S(selector is still the old one).

Restarted system a couple of times, and even regenerated they key, 4 times using the option to regenerate the key, and 5 times disabling the whole thing and re enabling it.

Help needed :smiley:


when I run opendkim-testkey I get
opendkim-testkey: key default: ‘202011._domainkey.%’ record not found
opendkim-testkey: key 1608923201159731: ‘’ record not found


I solved it and letting this sit here maybe somebody else gets into the same jam as me
I followed this:


  1. sudo apt-get purge --auto-remove opendkim
  2. sudo apt-get purge --auto-remove libopendkim11
  3. Navigate to VirtualMin->EmailSettings->DomainKeyIdentified mail
  4. Install the package that is presented

Operating system Ubuntu Linux 20.04.4
Webmin version 1.990
Usermin version 1.834
Virtualmin version 6.17-3
Authentic theme version 19.85.1
Kernel and CPU Linux 5.4.0-109-generic on x86_64

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.