DKIM for domains

I have DNS records set up for two domains so far. When I run DKIM from Email settings in Virtualmin, it only adds a record for one domain, and another that I have DNS set up on another DNS server. I tried adding the second domain to the “other domains to sign for”, but that didn’t work. How can I get it to create DKIM keys and records for each domain I have set up in BIND? Thanks!

To add domains to Virtualmin, are you using the Virtualmin -> Create Virtual Server menu option? Or are you using Virtualmin to set up each domain in BIND?

I originally added the domains using Create Virtual Server and handled the DNS from the VPS host. I then created DNS zones in BIND for two of the domains, one at a time and deleted the zones at the host. I am taking each step slowly so I don’t mess anything up. Using Email Settings in Virtualmin, it set up the DKIM record for the first domain when I set up the zone. I re-ran it when I sent up the DNS for the second, but it only set up the first one again.

DNS must be hosted on the same server for DKIM records to be added automatically by Virtualmin.

You could use Virtualmin as a simple GUI to configure your server, provided you know exactly what you are doing and the configuration changes that you need to apply to specific files to get the results you want.

For people who wish to use a server as, say, a virtual hosting environment, Virtualmin can also be used as a powerful and intelligent tool, rather than as a mere GUI, to manage entire workflows which implement sensible default values and reliable configurations for many operations such as the creation of virtual servers, creating users and email addresses under virtual servers and managing related quotas and limits.

It is up to you, @DavidG, how you wish to use Webmin + Virtualmin. If you had used Virtualmin -> Create Virtual Server menu option then it would have all just worked; but if you use the GUI to apply configurations on whim then you are pretty much on your own. I don’t think many of these forums will be able to divine what the current status of your system is after the changes you have made and what to suggest you do next to get the results that you want.

If ever you start with a fresh Virtualmin install, you should consider using the Virtualmin -> Create Virtual Server menu option to create a virtual server, with web and email disabled, and then change DNS settings for the domain associated with the newly created virtual server to whatever you wish them to be. In this way, the rest of your system will remain operational; even if that particular virtual server is kept on if it works as you desire it to work or removed via Virtualmin -> Disable and Delete -> Delete Virtual Server.

Actually, that is pretty much what I did. I used Create Virtual Server for each domain, but did not have the system set up DNS zones because the DNS was set up somewhere else. Since I understand that the zones have to exist on BIND in Webmin/Virtualmin, I then created the zones for each domain in BIND and deleted the remote records. The domains are operating correctly. The websites are accessed and mail is being sent and received. The only problem is to get the DKIM process to recognize the domains added after the first one. Does an existing TXT record need to be present when running the process? Are keys generated for each domain, or can the TXT record in the first domain be copied to the other zones?

Yes, the DNS for two of my domains are on the server. I have the same records for each. The domains are operating correctly. The websites are accessed and mail is being sent and received. The only problem is to get the DKIM process to recognize the domains added after the first one. Does an existing TXT record need to be present when running the process? Are keys generated for each domain, or can the TXT record in the first domain be copied to the other zones? Thanks!

:x:

You should have simply: Virtualmin -> Edit Virtual Server -> Enabled Features checked the box next to ‘DNS domain enabled’.

I will try that – Thanks!

If Virtualmin -> Edit Virtual Server -> Enabled Features check the box next to ‘DNS domain enabled’ throws an error, try removing the zone from BIND. Basically undo the things which you had done manually and then try again.

1 Like

My 2 cents for this issue is google it…really do.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.