DKIM does not show the key needed for DNS

The first time I did Virtualmin > Email Settings > DomainKeys Identified Mail it worked fine.

I did not like the selector - which may have been “default” the first time, so I did it again.

But it does not show the key I need to put in my DNS hosted elsewhere. Have tried many times now.

I read in some posts that there was a problem caused by using “default” as the selector and that it had been fixed, but on my fresh installs - several - it always shows “default” for the selector.

Appreciate any help. Thanks

How? Did you install opendkim again?

You do know that the key is generated based on the contents of /etc/dkim.key (or similar) and you must apply the old dkim.key file for the old keys to be valid. In your operations to get a vanity selector if you have lost your old dkim.key then you now have no other option but to tediously change every DKIM entry for every domain in your third party DNS control panel. :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.