Disabling SSL on virtualhost


I have a webmin/virtualmin server with a single IP address.

SSL is activated for the webmin control pannel.

For my virtualhosts, I have disabled SSL in the “Enabled Features” section of each virtual host.

In the “configure Website” -> “SSL Options” section, “Enable SSL” is also set to “No”.

but even if SSL is disabled, if I go to https://MyVirtualHost1.com I got a empty page “Index of /” with the “Name”, “Last modified”, “Size” and “Description” headers. No file are listed.

How can I remove this so HTTPS return an empty page (404?) or redirect to http?

I got an email from googlebot saying that the certificate for that page was wrong since it’s the self signed certificate from webmin, signed for “webmin.MyServer.com”.

Thank you.

I want to disable access via HTTPS to a given virtual host. In my case it is because I am using an SSL certificate for another virtual host that is also used in Webmin, but it is somehow being used for the virtual host for which I want to disable SSL access.

I’ve been contacted about this and have received complaints that there’s an SSL site available but the certificate’s name does not match the website domain.