Disabling SSL not working

Hello, I have dedicated server running on Centos6. I installed Webmin and configured my domain as http://example.com and installed a RapidSSL certificate.

I did try to disable SSL, but then i can’t access https://example.com.

When I am trying to connect to http… it works perfectly alright. Only problem is with https…

When I am trying to connect to https it isn’t open from “/home/…/example.com/public_html”, but redirect to “/var/www/html/”.

Can you help me solve this problem?

Howdy,

Hmm, the existing default section of the Apache config may be overriding your new SSL setup.

Can you post the contents of your /etc/httpd/conf.d/ssl.conf file?

I suspect it’s something in there causing the issues you are seeing. Thanks!

-Eric

# LoadModule ssl_module modules/mod_ssl.so # ... ## ## SSL Virtual Host Context ##

Use separate log files for the SSL virtual host; note that LogLevel

is not inherited from httpd.conf.

ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

SSL Engine Switch:

Enable/Disable SSL for this virtual host.

SSLEngine on

Server Certificate:

SSLCertificateFile /etc/pki/tls/certs/localhost.crt

Server Private Key:

SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

# LoadModule ssl_module modules/mod_ssl.so # ... ## ## SSL Virtual Host Context ##

<VirtualHost default:443>

Use separate log files for the SSL virtual host; note that LogLevel

is not inherited from httpd.conf.

ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

SSL Engine Switch:

Enable/Disable SSL for this virtual host.

SSLEngine on

Server Certificate:

SSLCertificateFile /etc/pki/tls/certs/localhost.crt

Server Private Key:

SSLCertificateKeyFile /etc/pki/tls/private/localhost.key