Disable SSL in Usermin

I think I have it all sorted out except one thing.

I need to disable the use of SSL within webmail.

I don’t wish to mess around with buying a cert for this server (which is only temporary) but I don’t want to explain to the users that they have to accept a certificate which is not authentic. If you see what I mean.

In Usermin, SSL Encryption, there is an option “Enable SSL if available? Yes/No” which I have set to off.

If I try to go to “webmail.domain.com” the browser tries to go to https://rtw-domain.com:20000/

Which fails.

If I try to go to domain.com:20000 all is ok.

I can’t find anything to configure this and I could not find any previous posts.

Anyone got any ideas ?

Thanks for reading

Oops ! sorry for the typo above.

The line which reads :

If I try to go to “webmail.domain.com” the browser tries to go to https://rtw-domain.com:20000/

should read

If I try to go to “webmail.domain.com” the browser tries to go to http://domain.com:20000/

(Hangs head in shame)

Yeah, the redirection is a Virtualmin setting – you can tweak that in System Settings -> Server Templates -> Default -> Apache Website.

In particular, the option you’d want to change is “URL for webmail redirect”.

That would only change new sites.

To change existing ones, you’d either need to manually update the individual VirtualHosts in the Apache config, or use the command line tools to disable webmail, then re-enable it for everyone. This is an (untested, but I think it’ll work) example:

virtualmin modify-web --all-domains --no-webmail

Then re-enable it:

virtualmin modify-web --all-domains --webmail

Many thanks.

I was able to edit Apache Config and fix it on the already created VH. Brilliant.

I don’t have a clue as to what I should enter in the text box for Settings -> Server Templates -> Default -> Apache Website though.

Obviously the radio button needs selecting, but what goes in the box.

Sorry to be such a thick pain in the butt.

I have to say, I like Virtualmin a lot. Guess I will be installing on the new server when we get to it. Unusually for me (because I am a tight so-and-so) I really think the Pro version must be worth the money.

Thanks again

Well, what exactly goes in that partly depends on your setup.

But to have it continue to act similar to how it sounds like you have things today, but with “http” rather than “https”, I think you could use something like this:

http://www.${dom}

Regarding the Pro version – there’s a Demo setup on the server here that you can use to try it out (erm, the link seems to not be up yet, but Joe is quickly working to solve things like that :wink:

One of the more popular features it provides is the Install Scripts, which allow your users to install any of 80+ web apps by just clicking a button (Wordpress, Gallery, Drupal, Magento, etc). Future upgrades of them are similarly easy.
-Eric

Thanks Eric.

At the moment the box is empty, but I will try http://www.${dom} as you suggest.

That will have to be tomorrow now, it has been a 15 hour day for me today.

Thanks again.

I get the feeling that I will never understand the strange kind of magic which seems to be infest the world of IT.

I tried “http://www.${dom}” as you suggested, but it didn’t produce the results I was expecting.

From the directives of a new VH :-

RewriteEngine on /etc/httpd/conf/httpd.conf (1082)
RewriteCond %{HTTP_HOST} =webmail.test.co.uk /etc/httpd/conf/httpd.conf (1083)
RewriteRule ^(.) http://test.co.uk:20000/ [R] /etc/httpd/conf/httpd.conf (1084)
RewriteCond %{HTTP_HOST} =admin.test.co.uk /etc/httpd/conf/httpd.conf (1085)
RewriteRule ^(.
) https://test.co.uk:10000/ [R] /etc/httpd/conf/httpd.conf (1086)
Alias /dav /home/test/public_html /etc/httpd/conf/httpd.conf (1087)

Putting “http://www.${dom}” in “URL for webmail redirect” changes the third line to “http://www.${dom}”.

I tried various variations but no joy.

Then I deleted that entry and went back to default and it seems to work! I guess I will only know for sure when I create a new hosting for real.

As I said, there seems to be some kind of strange magic happening and it all seems to be OK.

Thanks again, I will now go and sit in the corner and be quiet again.