"Disable now and on boot" button not working with Debain 7

Hi There,

From: >System >Bootup and Shutdown I’m trying to disable:

  • bind9

  • spamassassin

  • clamav-freshclam

  • clamav-daemon

But after restart these items are still running - at least, that’s what Virtualmin states.

Is there a way to check if they’re actually running from the command line?

Cheers

Ben

So have found a couple of commands to check, and after rebooting I can see that the services are running after reboot using:

$ service bind9 status

$ service clamav-freshclam status

$ service clamav-daemon status

If the “Disable now and on boot” button in Virtualmin doesn’t work for you, you can do it from the command line like this:

Stop a service:
$ service bind9 stop

Disable at startup:
$ update-rc.d bind9 disable

Reboot the server:
$ reboot

Check if it’s running:
$ service spamassassin status

Rince and repeat for services you wish to disable by replacing the service name with the name you see in Virtialmin like this:

$ update-rc.d clamav-freshclam disable

If there’s a better way to do this, please sing out as I’m fairly green when it comes to the command line.

Cheers