Default settings for sub-servers - PHP

I just had my Monday headscratch-a-thon. The default settings for top level domains for PHP is fcgid, and the default for sub-servers is mod_php.

I think it should also be fcgid out of box as well, I was having all kinds of permissions issues this morning until I realized what is going on.


Hmm, the default should be FCGID for all domains, not just sub-servers.

What distro/version are you using there?

I’ll do some testing to try and reproduce that issue, as mod_php is actually considered a security risk on a multi-user server.


CentOS 6 i386, two installs had that setting, I don’t remember running into that issue before, maybe something weird happened. They were on VMware using the CentOS minimal ISO.


Hmm, thus far I haven’t been able to reproduce that issue.

Do you know if, on either of those setups, any Virtualmin settings had been imported?

If there were settings from a virtualmin.tar.gz file that were imported, that could have brought in a Server Template that contained a Sub-Server plan containing that particular setup.

Another possibility, do you know if there was another repository of some sort that had been enabled? A third party repository could cause that sort of issue, if PHP were pulled in from there.


I just did two test installs on CentOS 6.5 i386 on VirtualBox, I got the same results each time.

“Default Settings” template is fcgi
“Settings For Sub-Servers” template is mod_php

This was a clean install from the minimal ISO, I booted it up, ran yum update, then installed virtualmin with the script.

I just did another install on CentOS 6.4 i386 on OpenVZ, I used the centos-6-x86 template provided by the openvz team.

Same result as above

I just found the same problem on a server I setup on “13/Aug/2013” I checked the actions log, no changes to the subserver template.

It seems something is switching the subserver template to use different settings then the default top level domain template.

This was on CentOS 6 x86_64 / OpenVZ

Out of curiosity, if you look in System Settings -> Server Templates -> Settings For Sub-Servers -> Apache Website, is the “Default PHP execution mode” option grayed out? Or are you able to select options from that?

If it’s not grayed out, what option is it currently set to?


The options are all filled in, like the settings were copied from the main template, here is a PDF of what the page looks like. No changes were made to anything.

Install centos -> update -> -> first run wizard -> look at default settings for sub-servers template

I have now seen this 6 times so far, I am checking other installs I have done recently as well.