Default server for port 443 (TLS)

I have a default server for normal requests (port 80) that I set by going to Sever config >> website options >> Default website for IP address.

However this does not seem to be working as the default server for secure requests (443). In that case another virtual host’s home page is displayed. So, how can I set that?

Thanks.

Howdy,

Not all domains would have a website setup on the SSL port (443). Does this particular domain have an SSL certificate configured?

-Eric

Yes, the default domain does Eric.

Look in: Webmin -> Servers -> Apache Webserver

You could set up a virtual host just for port 443

What you are seeing is the default server located in the above location.

The files come from the /var/www/html folder

The work around for this is to create a virtual host just for port 443 that handles any address and set the default path to where ever you want or redirect it to another location.

Look in: Webmin -> Servers -> Apache Webserver

You could set up a virtual host just for port 443

What you are seeing is the default server located in the above location.

The files come from the /var/www/html folder

The work around for this is to create a virtual host just for port 443 that handles any address and set the default path to where ever you want or redirect it to another location.

Hi Shane

On CentOS 6 I have one Apache file at etc/httpd/conf/httpd.conf. That contains all the Virtual Host definitions from Virtualmin.

When that part of the conf file starts, the first entry for a particular port becomes the ‘default’. Perhaps because I had enabled TLS for my default at a later date, the section for port 443 for that server was near the end of the list! So I cut it and pasted it below the section for port 80, and now that has fixed the issue.