Default script installers no longer shows scripts

I’ve been working with Virtualmin for about a month, have written an Installer Script in perl, and have been setting up templatees with ease.

Today I was surprised when I went to modify the Script installers for a package, only to discover what’s might be a Virtual min bug.

I’ve attached a screenshot.

Visiting any page having to do with Script installers will NOT display the list of available installers. Instead, it will just display this message:

/home/test-cc-1000/public_html Fixing permissions… Ran with no errors

That happens to be the message that last got displayed when I last created a test account.

TO REPLICATE THIS:

  1. Log into Virtualmin as root

  2. Click on Server Templates

  3. Click on Default settings

  4. In the select list, choose Default script installers
    You won’t get a list, you’ll instead get:
    /home/test-cc-1000/public_html Fixing permissions… Ran with no errors

Any help appreciated. Is this a known bug, with a known patch?

Thanks!
Emily <br><br>Post edited by: emduck, at: 2008/09/23 16:58

Excellent question, and nice screenshot and debugging info. Unfortunately, I have no idea :wink:

However, I might recommend filing a bug (and just repost everything you put here), where Jamie would see it and be able to help you out:

http://www.virtualmin.com/bug-tracker/

Thanks,
-Eric<br><br>Post edited by: andreychek, at: 2008/09/23 18:42

My bad. It turns out I had a script in the installer scripts directory which prints something out. That’s a no-no for installer scripts. Jamie gave me that tip on the bug tracker forum–
http://www.virtualmin.com/index.php?option=com_flyspray&do=details&task_id=4599

Thanks!
Emily