Default MX record suffix - how to customize it

Hi,

By default Virtualmin sets mail.domain.com as the default A and mx record when enabling mail for a virtualserver.

The problem is that if mail. is already defined on other servers that you get an error (unless you use the same ip as the other server which is unlikely in most senarios).

We can add dns record in the template BUT when enabling mail somehow Virtualmin interact with whatever mail server installed (postfix in my case) and set mail. as the default A and mx record.

Where can I change these default values if possible? I did customized many dns records BUT for mail I see nowhere to do it.

Regards,

Howdy,

Hmm, what error is it that you’re getting exactly? And where do you see that error?

-Eric

Well,

If I look at the dns records (for the given domain) I get a red warning on top that says my mx record point to the wrong place and that I need to disable mail or correct the offending record.

Regards,

Can you re-iterate the situation please? I don’t fully get it. :slight_smile: I.e. where is your mailserver located if not on the Virtualmin host, and why would you need to turn on the Mail feature if the mailserver IS located elsewhere?

Virtualmin is trying to tell you that it’s a contradiction to turn on the Mail feature (i.e. telling it that your local system is going to serve email), while the MX record points to a different system at the same time.

Yeah, as Locutus mentioned, if mail is actually being hosted elsewhere, and not on your Virtualmin server – it would actually cause problems to enable the “Mail for Domain” feature.

In that case, Postfix will try to deliver email locally, regardless of where the MX record points.

-Eric

Hi,

yes it makes sense BUT I am trying to migrate from an awfull system onto a Virtualmin based one using the same domain name, that is why.

I disabled mail on the Virtualmin based one so its ok I will manage as is. I was wondering if it was possible as is for most DNS related records to customize the mail suffix for default mx records.

Regards,