Default index.html not editable from /etc/skel


The feature of creating a index.html file upon creation of a new virtual server is good with the initial content, but can you tell me from where I can either remove this feature or change the
content of this html.

I tried to create a folder public_html inside /etc/skel, directory with a custom content like init.txt with some hello content, this works fine and the new file init.txt is created successfully.

But when i create another file with the name index.html inside /etc/skel/public_html with my custom content, then it is not created and the default file with the content of Virtualmin is left untouched, any ideas, what I am doing wrong here.

I tried to recheck the configurations after making changes but still it is not fixed.


I’m pretty sure you can set that in Server Templates, maybe? It’s definitely configurable.

That said, the fact that it doesn’t respect skel is a bug. That’s the whole point of skel.

I’ll check in with Ilia and Jamie, as they implemented this feature.

OK, apparently it’s not configurable. That’s a bug.

In Virtualmin Pro, you can choose “No” in the " Create initial web page? field, and it’ll respect /etc/skel. In Virtualmin GPL, there is currently no way to get /etc/skel, but this will be fixed soon.

Thanks for the reply, can we have a quick fix which I can do to resolve this issue.

Also, is there a way to roll back to 6.09? from git or any where else.

The reason I am looking for a fix of this issue is that I am creating domains using API and I didn’t find any flag to disable the initial website content in the apis, which is actually blocking the further requirements.

If you’re scripting it, just delete /home/domain/public_html/index.html or copy your preferred default over it.

I don’t recommend rolling back to 6.09 (it has a couple of annoying bugs relating to mail). I’m not sure if it’s still in the repos, but probably. You can use yum downgrade or apt-get install with the specific package and version you want. We always tag releases in github, as well:

Again, not recommending it.

I don’t have a quick fix. I don’t know this area of the code, and Ilia’s taking a few days off (and, I’m swamped with other stuff, so I doubt I’ll be able to get to it). You could probably dig up the patch that made the change in git though…there are a lot of changes between 6.09 and 6.10 (huge release…too big for the three of us to really handle well, as the messiness of it indicates), but, I suspect it’s a pretty obvious one. This file is probably the one to look at for the history. I guess you could even just replace that file in the install directory. It’d get overwritten on updates, but we’ll probably only have one more version that doesn’t allow changing it (we need to roll a new bugfix release soon and we won’t have time to fix this one, as it’s big and has UX problems).

Thanks for the location of file it will surly help.

Hi Joe,

One question, where I can find this file in the installed Virtualmin, mean the location of installation, I did find the /var/webmin folder but folder specific to virtualmin are not found, can you please help me in locating this file

Thanks is not the file you should modify.

I linked to index.html that was added for this new feature. /var is for logs and cache and stateful data. Webmin and modules live in /usr/libexec/webmin or /usr/share/webmin.

Thanks a lot, got the file and now able to modify it, also I am able to downgrade the virtualmin from webmin modules to 6.09 for now till the issue is fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.