Default Apache DocumentRoot

For consistency, I am trying to change the name of the default apache folder from html to httpdocs.

I have altered my 000-default.conf file (as shown below) but when I run apachectl -s it still shows as html as so…

VirtualHost configuration:
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex authdigest-client: using_defaults
Mutex fcgid-proctbl: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
Mutex fcgid-pipe: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy-balancer-shm: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: “/var/run/apache2/”
User: name=“www-data” id=33
Group: name=“www-data” id=33

Where is this stored or is it hard coded?

My 000-default.conf file is

# The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request's Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName
DocumentRoot /var/www/httpdocs

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Any help appreciated.

000-default.conf is disabled during Virtualmin installation because trying to use a “default” along with VirtualHosts can lead to confusing and difficult to troubleshoot behaviors (like Apache serving the wrong site).

We recommend you not use a “default” site, at all, and instead create a domain in Virtualmin for every website you want to serve from the system.

If you really want it back, you can re-enable it with a2ensite 000-default, but I’d be willing to bet it’ll cause you more headaches than you want.

Nope, that’s fine thanks Joe. I’ll just ignore the folder (or maybe delete it). I’m merging my sites to sub-servers so I can get rid of the ever increasing number of domain names I have and have started over completely so will have a main domain which will be set as default.