Debian squeeze + xen-4.0 problems

I am starting this new topic for all problems regarding Debian squeeze-amd64 + xen-4.0 + cloudmin
Please feel free to post any problems that you all encounters in this specific scenario.

I will start this by posting several problems and hope that i could get some answers for me and for others who will search.

  1. In debian squeeze 6.0.1a there is no such thing like libc6-xen and the script for installation for cloudmin fail at that point, so i comment that line up where he check for libc6-xen.

  2. script for installation on debian it’s old so i have installed manually
    xen-hypervisor-4.0-amd64 \n
    xen-linux-system-2.6.32-5-xen-amd64 \n
    linux-image-2.6.32-5-xen-amd64 \n
    xen-qemu-dm-4.0 \n
    xen-tools-4.0 \n
    bridge utils \n
    lvm2 \n
    bridge-utils \n
    vlan \n

The installation script keep trying to install xen-3.2 which is not the last stable version. (it should be updated)

  1. After i install cloudmin i have import all images that cloudmin let me download.
    First i have made a vps with debian squeeze -full virtualized, it works great, i could get into ssh and vnc and test it.

VNC -from web administration it works great but console from from web administration stuck like

Root shell:

On black screen writed with white:
“Opened shell on xen1.cloudmin.test …

here i cannot write anything but i can connect it via ssh putty or via vnc from other computers 

In left corner it’s a “.” dot that blink every time i press a key.
I have try other browser other then mozilla , and from other computers but same thing.
Root shell it’s appear with black screen with that 2 rows but cannot write anything.

  1. When i create a vps lets say 15gb storage 2gb swap on lvm, it makes both lvm images but on 15gb storage he makes only 1gb partition for / and let the rest empty, how can i configure that on a 15gb virtual hdd to make a single partition of 15gb and mount / on it.

  2. i just can’t figure it out what are images from cloudmin that ends with Wirtualmin GPL like:

    CentOS 5.4 Xen instance with base OS
    CentOS 5.4 Xen instance with Virtualmin GPL
    What is the difference between those two?

  3. Is there any tutorial how to install para-virtualizated vps?
    If in this case i use debian squeeze as host, i know from other test that i can install and debian/ubuntu/kubuntu (same family) para-virtualizated systems but how about making a centos para-virtualizated system on debian host? can i do that? Some tutorials seems to find a way to work but i couldn’t do it.

Sounds like there are several bugs here … I will respond point by point :

  1. The installer should just ignore this failure already and continue…

  2. I will update the installer to install Xen 4.0 if available.

  3. This could be an issue with the browser-based SSH client. Can you connect with SSH directly?

  4. That’s odd, the / partition should get expanded to fill up the whole disk. Which image did you use?

  5. The ones with “Virtualmin GPL” in the name contain Webmin, Virtualmin, Apache, MySQL and all the other packages needed for web hosting by Virtualmin.

  6. Most images can and will be run para-virtualized by default. However, the Squeeze image cannot be as it uses grub2 which has a different config format to classic grub which Xen pygrub doesn’t support :frowning:

Thank you for your quick answer .

3 .From putty i can connect very well and vnc from web based works great. But when i try root shell i have
a black page like i said with two white lines “Opened shell on xen1.cloudmin.test …” and i have ‘#’ sign
for root prompter.

4 .i have used Debian squeeze image:
“Debian Squeeze Xen instance with base OS”

5 .Please explain to me this in much more details.
It’s like i can’t make a para-virtualized debian squeeze vps on a debian squeeze host because of grub2? well i have did that manualy, i will post my cfg file in my next message, and maybe we can figure it out how to automate that in cloudmin. (please wait for my next reply on this point)

How about centos, can i install centos who has grub1 on debian squeeze host who has grub2?

6 .My host server has a xeon 3440 processor, and linux show 8 processors 0-7, how can i dedicate 2 processors to a vps in cloudmin when in configuration i can select “Maximum CPU use” in percent %.
It’s like i suppose to select 25% for 2 processor from 8 available? i did that but when i run xm list i see my vps with only 1 processor from 8 instead of 2. Also i did cat /proc/cpuinfo in my vps and i see 1 processor instead of 2.

I know i am wrong maybe but tell me how to configure “New system > Create xen instance” with 2 processors.

I am trying to make a new Debian based OS vps on my debian squeeze host i will post next details:

This cfg it was made by cloudmin webinterface at new xen instance:

root@xen4:~# cat /xen/xent2.cfg

memory = 768

name = ‘xent2’

vif = [ ‘ip=,mac=00:16:3e:58:CC:C2,bridge=br0’ ]

address = ‘’

netmask = ‘’

disk = [‘phy:/dev/xen/xent2_img,sda1,w’,‘phy:/dev/xen/xent2_swap,sda2,w’]

on_reboot = ‘restart’

on_shutdown = ‘destroy’

on_crash = ‘restart’

on_poweroff = ‘destroy’

kernel = “/xen/vmlinuz-vm2-xenU”

ramdisk = “/xen/initrd.vm2.xenU.img”

root = “/dev/sda1 ro”

vnc = 1

vnclisten = “”

vncunused = 1

vncpasswd = “cloudmin”

vfb = [‘type=vnc,vncunused=1,vncpasswd=digicom,vnclisten=’]

This is what i get after restart: from vnc:

It is because of grub2 from host machine? what can i do to make this work right.

Thank you very much

P.S. how can i write a post here with lines ended with “\n”. I am trying but it seams it show each line next to other like a paragraph

Yes, that error about not being able to find /dev/sda1 is typical of the problems I saw with Squeeze VMs running para-virtualized. I presume this VM was created from the Squeeze image?

Other distributions like CentOS 5 and Debian 5 use grub 1, and so don’t run into this issue. If you want to run Squeeze, you have no choice but to run it fully virtualized until Xen adds support for the grub 2 format.

That was actually Debian 5 vm and i have same error with CentOS 5.4 vm i have same errors

It’s like i cannot install nothing para-virtualized.

Thank you for your answer and i will come back with a config that works squeeze on squeeze para-virtualized and maybe you can help me do that cfg with cloudmin interface, wait for my reply for this issue.

You didn’t answer for questions up 2 posts about how to configure vm machine with 2 processors instead of 1
I hope you will have time to explain to me how to do this.

Like i said i have test a para-virtualized guest manually without couldmin and it works:

  1. xen-create-image --hostname=xen6.test --size=4Gb --swap=256Mb --ip= --memory=256Mb --arch=amd64 --role=udev

  2. This command from (1) it make a new vm cfg:

root@xen4:/xen# cat /xen/xen6.test.cfg


# Configuration file for the Xen instance xen6.test, created

# by xen-tools 4.2 on Tue Jun 7 12:18:26 2011.

# Kernel + memory size\

kernel = ‘/boot/vmlinuz-2.6.32-5-xen-amd64’

ramdisk = ‘/boot/initrd.img-2.6.32-5-xen-amd64’

vcpus = ‘1’

memory = ‘256’

# Disk device(s).

root = ‘/dev/xvda2 ro’

disk = [

# Physical volumes

# Hostname’

name = ‘xen6.test’

# Networking

vif = [ ‘ip=,mac=00:16:3E:66:6C:A3’ ]

# Behaviour

on_poweroff = ‘destroy’

on_reboot = ‘restart’

on_crash = ‘restart’

  1. Then i write xm create xen6.test and after that xm console xen6.test and ai get:

  2. So manually i can create a para-virtualized guest in xen squeeze host, but how do i do that with cloudmin?

I am waiting for your answer, meantime i will try to make manually para-virtualized guest like debian 5 or even centOS. (i will post results)

Thank you very much

Sounds like we need to do some more testing on Squeeze … I’ll take a look into this.

I have an idea!

I did some research and i found next information:

“Xen 4.0.1 changes”

# Pygrub support for booting Xen PV guests using GRUB2 config files (Ubuntu 10.04 LTS, Debian 6.0 Squeeze).

My last simple question is: can you make a xen-4.0.1 or xen-4.1.0 deb squeeze package?
I know this is way too far from cloudmin subject but really if you can do that for community it will be great i mean it will solve lots of problem if you do this deb package and include it to webmin repository and include it also in installation script of cloudmin.

I have tried to understand cloudmin scripts but its so hard, i mean i know Perl but there are scrips with over 10.000 lines and i am lost at some points :slight_smile:
So i ask you if you can improve this solution for debian squeeze.

You must understand that debian squeeze its the actual debian distribution witch all are focused on to, not debian lenny, you even can’t find to download debian lenny from debian ftp mirrors.

Thank you very much.

Sorry for last post it seems that debian already work at xen 4.1 deb package
It’s just unstable version but otherwise it should work.

So i guess we just hate to wait for stable version of xen-4.1 package or compile xen-4.1 from sources

I think I will just wait for that package, as if pygrub can support grub 2 it would solve most of these problems…

I have resolved all issues from this topic, if someone have question i will still watching this topic

I have Cloudmin 6.2 KVM running and see the same issue (your issue 3.) with the root shell:

On black screen writed with white: "Opened shell on …
here i cannot write anything

You have resolved this ?

Thanks for any help!