debian lenny + new virtualmin through script...

I have clear debian 5 installation + installed through script virtualmin, webmin, etc.

  1. I’ve created virtual server and put through ftp Joomla 1.5.9 files. when I tried to setup Joomla I had this message:

PHP Version >= 4.3.10 Yes

  • Zlib Compression Support Yes
  • XML Support Yes
  • MySQL Support No !!!
    MB Language is Default Yes
    MB String Overload Off Yes
    configuration.php Writable No !!!
    Display Errors: On !!!

so, I tried to check php settings, but webmin PHP CONFIGURATION module showd me this message:
No PHP configuration files were found. Adjust the module configuration to set the correct path to the global PHP config file.

  1. According to this url http://www.virtualmin.com/forums/news/webmin-version-1.470-and-usermin-1.400.html#22125

Improved support for FreeBSD 7.1 and Debian Lenny across multiple modules.

…support for debian lenny was improved, but why We have 1.450 webmin in virtualmin repos now?<br><br>Post edited by: denisius.sion, at: 2009/03/21 14:55

Howdy,

A few questions first –

  1. How did you go about installing Virtualmin, did you use the install.sh script, or did you pull down the virtualmin.wbm module from webmin.com?

  2. What version of Virtualmin are you using, Pro or GPL?

Regarding the Webmin version – I just verified that Webmin version 1.470 was available in both the Pro and GPL repositories for Lenny. If you run "apt-get update && apt-get upgrade", does it show Webmin as an install option?

Regarding the PHP/Joomla issue, are you using suexec, or are you by change running without that, possibly with mod_php?
-Eric

  1. I said before I used install.sh and clear debian lenny amd64.
  2. No I still didn’t upgrade virtualmin to Pro version. I want to be sure that everything works normally in GPL version.

>>If you run "apt-get update && apt-get upgrade"
Yes I did it :). and it show me 1.450 latest version. Check please amd64 repository.

As for PHP, I said before I didn’t change enything in webmin/virtualmin, I just installed it using install.sh to fresh debian 5 and the have created new server. In appache configuration by default enabled suexec and mod_php. The problem is that default configuration after installation through install.sh doesn’t work normally.

Thanks for any answers!!

Yes I did it :). and it show me 1.450 latest version. Check please amd64 repository.

It’s in there. Have you got the virtualmin-universal repository configured? I’ve divided out the Webmin/Virtualmin/Usermin packages into their own repository for Debian, beginning with lenny. It makes it easier to maintain for me, and easier for folks to selectively make safe use of our repositories on unsupported versions of Debian (or Ubuntu). And it’s more similar to the way we’ve always done things on RPM-based distributions.

In appache configuration by default enabled suexec and mod_php. The problem is that default configuration after installation through install.sh doesn't work normally.

suexec doesn’t apply to mod_php. It can’t, as mod_php is a completely separate execution path.

You can either set the configuration.php file to be group writable (assuming Apache is in the virtual server owners group), or you can switch to CGI or mod_fcgid. I’m pretty sure there’s a stickied thread about how to do the latter…if you can’t find it, let me know, and I’ll dig up the thread where I documented suexec with PHP and fastcgi configuration with Virtualmin GPL.

The mod_fcgid stuff is actually a feature of the Install Scripts capability in Virtualmin Professional…so it shouldn’t be expected to magically work on Virtualmin GPL. This may eventually change, but it’ll require some code refactoring to expose the feature outside of Install Scripts (which will never be in GPL, because they require so much resources to maintain).

- MySQL Support No !!!!!!!!!!

So, install the module using apt-get and restart Apache. This should have been done by the install script…but, I guess something went wrong.

No PHP configuration files were found. Adjust the module configuration to set the correct path to the global PHP config file.

This one is suspicious. Where’d you get your PHP from? The default OS package ought to put the php.ini in the place Webmin expects.

It's in there. Have you got the virtualmin-universal repository configured? I've divided out the Webmin/Virtualmin/Usermin packages into their own repository for Debian, beginning with lenny.
But.. as I understand install.sh should add these repos to the sources.list? anyway please post here your ideal sources.list for debian lenny amd64.
suexec doesn't apply to mod_php. It can't, as mod_php is a completely separate execution path.

You can either set the configuration.php file to be group writable (assuming Apache is in the virtual server owners group), or you can switch to CGI or mod_fcgid.

I need php 5 as apache module. But I want to use suexec because I want that users will have enough permissions to work in ftp with files which were copied through http.

So, install the module using apt-get and restart Apache. This should have been done by the install script...but, I guess something went wrong.

I have attached log, please look it maybe it will clarify problem.

So :slight_smile: one more time - my steps: I’ve installed debian 5 lenny (only base packages), download install.sh and have executed it. then opened in browser webmin. I didn’t make any anather steps. One more time - clear debian 5 amd64 iinstallation!

Thanks for any answers!!!

Sorry for double post I cannot delit it!

Here attachment - log file [file name=virtualmin_install-e6ad6768d677c32c67d5fabe30a78e71.txt size=96252]http://www.virtualmin.com/components/com_fireboard/uploaded/files/virtualmin_install-e6ad6768d677c32c67d5fabe30a78e71.txt[/file]

Joe, the Pro repository looks fine, but the “packages” files for the Debian GPL virtualmin-universal repository haven’t been updated for a few weeks.

I suspect that may be causing the issue that he’s seeing :slight_smile:
-Eric

So when it will be updated? I want to try one more installation to clear debian 5 for testing, before I’ll use it on our dedicated server.

Joe’s on the west coast, so it’ll be at least several more hours before he’s even awake. I imagine he could have it updated today, but it’s at the very least a few hours away :slight_smile:
-Eric

OK, so I officially hate the apt repo creation tools. I have no idea why my script isn’t working any more. Looking into it.

we believe in you :). So when it will work normally? :slight_smile: Really I was waiting for install.h for 1 month, so how much I should wait more?

The install.sh should work fine for lenny. We’re just talking about the Webmin and Usermin updates.

I said:

suexec doesn't apply to mod_php. It can't, as mod_php is a completely separate execution path.

And you replied:

I need php 5 as apache module. But I want to use suexec because I want that users will have enough permissions to work in ftp with files which were copied through http.

Should I try to rephrase it? OK, here goes:

You cannot use PHP 5 (or 4 or anything else) as an Apache module if you want to use suexec. You cannot. Not because I say so…but because it simply doesn’t work that way. You can have both, but not for the same application (realistically not for the same path).

You have to choose how you want to run your application: suexec or mod_php. You can use suexec with mod_fcgid to make running under suexec roughly as fast as running under mod_php. But suexec does not effect scripts running under mod_php…no matter how much you might want it to.

I believe the repos are up to date now, and I believe me repo update scripts are working.

I did a complete overhaul this afternoon of the maintenance scripts and the repositories…they were taking so long to complete that it was really frustrating to test them, so I cleaned up all the old packages and meta-data files, removed the sarge repo from the scripts, etc. So, repo maintenance and updates for Debian/Ubuntu should be easier and faster in the future. I still truly hate the apt repo maintenance tools. For yum, I run “create-repo -q /path/to/repo” with a single for loop. For apt, I’ve got two doubly-nested for loops, two big configuration files, and I have to run multiple apt-ftparchive commands. It’s madness. And, to add insult to injury, the docs for apt-ftparchive are just idiotically bad, and contain no working examples. But, I’ll stop belly-aching now. I think it’s fixed now and I probably won’t have to suffer through this again for a while. :wink:

ok…

So, can you look mu log file which I attached before… because it’s very interesting why Joomla says about mysql problem…

Also I have modified repos… but you didn’t update install.sh

if [ $os_type = "ubuntu" ]; then
deps=$ubudeps
case $os_version in
6.06*)
repos="virtualmin-dapper"
;;
8.04*)
repos="virtualmin-hardy"
;;
esac
else
deps=$debdeps
case $os_version in
3.1)
repos="virtualmin-sarge"
;;
4.0)
repos="virtualmin-etch"
;;
5.0)
repos="virtualmin-lenny virtualmin-universal"
;;
esac
fi

And “Download” page in this site still doesn’t updated, you should add Debian 5 to OS list. Now I try to launch install.sh again in clear debian 5, then I’ll write does it work or not.

Thanks for your time!.

ok, now repository is working and I have 1.470 webmin after finish of installation process:)

but another problem /dav doesn’t work for user, I see this message in my browser, and of cource I wrote right password/login and checked that dav was enabled for that user:

Forbidden

You don’t have permission to access /dav/ on this server.
Apache/2.2.9 (Debian) DAV/2 SVN/1.5.1 PHP/5.2.6-1+lenny2 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g Server at 192.168.0.128 Port 80

So problems still exist after installation. MySQL doesn’t work by default, file permissions, and php problems as I described before.

In Documentation it is written that after install.sh I can use system… But it’s not like this.

for mysql problem I’ve found this topic http://www.virtualmin.com/forums/help-home-for-newbies/re:vm-gpl-missing-mysql-connection-in-php5…html which has helped me.

No PHP configuration files were found. Adjust the module configuration to set the correct path to the global PHP config file.

I don’t know if its to late or if its the exact same problem but I was getting this error with my GPL version.

What I did to Fix it was:
sudo find / -name php.ini

That came up with:
/etc/php5/apache2/php.ini
/etc/php5/cgi/php.ini
/etc/php5/cli/php.ini

Looking in Virualmin/webmin/PHP Module Config I had this:
/etc/php4/apache/php.ini=Configuration for mod_php
/etc/php4/cgi/php.ini=Configuration for scripts run via CGI
/etc/php4/cli/php.ini=Configuration for command-line scripts

So I changed it to:
/etc/php5/apache2/php.ini=Configuration for mod_php
/etc/php5/cgi/php.ini=Configuration for scripts run via CGI
/etc/php5/cli/php.ini=Configuration for command-line scripts

Problem solved, I was able to access me resource limits to fix the problem I was having in Joomla with 16mb not being quite enough.