Debian Etch Webmin 1.430 upgrade stuck

Hey There!

I was running Virtualmin/Webmin 1.420 on an Etch system and 1.430 came out so i decided to update but dpkg stucks at this point:

[code:1]Setting up webmin-virtual-server (3.59.gpl) …

There’s no error message or anything. Have you experienced the same problem?<br><br>Post edited by: ScOut3R, at: 2008/08/24 09:15


I think this has been reported in the issue tracker…but I don’t see it now. It is a bug in the security-updates package. I kinda think it’s fixed in the most recent release, which came out at the same time as 3.61.

Try running apt-get from the command line, to get all the latest packages. If the problem persists after the newest version of security-updates is installed, file a bug, and Jamie will work on it some more.


After apt-get update i still see version 3.59 in the repository.

As of the dpkg.log file it stucks here:

2008-09-10 08:03:33 status unpacked webmin-virtual-server 3.61.gpl
2008-09-10 08:03:33 status half-configured webmin-virtual-server 3.61.gpl

Apt-get output:

Setting up webmin-virtual-server (3.61.gpl) …

/tmp/.webmin/webmin-setup.out shows this:


  •        Welcome to the Webmin setup script, version 1.441        *

Webmin is a web-based interface that allows Unix-like operating
systems and common Unix services to be easily administered.

Installing Webmin in /usr/share/webmin …

Webmin uses separate directories for configuration files and log files.
Unless you want to run multiple versions of Webmin at the same time
you can just accept the defaults.

Config file directory [/etc/webmin]: Found existing Webmin configuration in /etc/webmin

Creating start and stop scripts…

Updating config files…

Changing ownership and permissions …

Running postinstall scripts …

Right now trying to upgrade to 1.441 but still the same happens.

Yeah, if you’re still having trouble doing the upgrade after upgrading everything else using apt, I’d go with Joe’s suggestion of filing a bug in the Bugs and Issues tracker so that Jamie can take a look.