Debian 5 Dovecot + Postfix problems

Hi,

I’m new to Webmin, but I’m not new user, so you can go technical on me.

I’m having trouble logging in to dovecot’s pop. It asks me for a password and it simply comes back with “authentication failed”.

I’m putting the right password for the right user (I’ve tried with user@domain.tld and with user.domain.tld because the user creation set up a username like that, the email with a . instead of @).

Basically, I believe dovecot’s not really “seeing” the users that exist.

I use postfix, and though I’ve got another problem in there (I had to set ip up as an open relay for now, 'cause it was blocking all emails sent to other domains and I couldn’t get SASL to work there…), I can send email through smtp.

Using Usermin I can send and receive emails with the user.domain.tld user

On mail.log, all I get from dovecot is simply this:

Sep 16 16:30:03 stock dovecot: pop3-login: Disconnected: rip=XXXXXX, lip=XXXXXX

I really need some urgent help here :slight_smile:

Hrm, can you try logging into Dovecot again, and show a few more lines before and after the time you’re attempting to log in?

It seems like there’d be more related info that that – even if just the line that says there’s a “Connect” before the “Disconnected” line there.

Also, do you see any unusual messages in /var/log/syslog or /var/log/messages?

If “user.domain.tld” is the username format that works from Usermin, that’s what you should use to authenticate to Dovecot as well, if that helps.
-Eric

Ok, the different types of lines I get in a # cat /var/log/mail.log | grep ‘dovecot’

Sep 16 14:51:36 stock dovecot: pop3-login: Waiting for SSL parameter file ssl-parameters.dat Sep 16 15:00:03 stock dovecot: pop3-login: Disconnected: method=PLAIN, rip=XXXXXX, lip=XXXXXX Sep 16 15:45:22 stock dovecot: pop3-login: Disconnected: user=, method=PLAIN, rip=XXXXXX, lip=XXXXXX, TLS Sep 16 16:04:17 stock dovecot: pop3-login: Disconnected: user=, method=PLAIN, rip=XXXXXX, lip=XXXXXX, TLS ep 16 16:42:44 stock dovecot: pop3-login: Aborted login (0 authentication attempts): rip=XXXXXX, lip=XXXXXX Sep 16 16:43:29 stock dovecot: pop3-login: Disconnected: rip=XXXXXX, lip=XXXXXX, TLS handshake

Same for syslog.

Just tried now without TLS (and allowing plain password) and I don’t get a login message, just this:

Sep 16 16:50:55 stock dovecot: pop3-login: Disconnected: user=, method=PLAIN, rip=XXXXXX, lip=XXXXXX

This is very weird…

Yeah, if it shows a specific user as logging out, there should certainly be a login message.

What if you just peruse the logfile manually, perhaps using the “less” command and jumping to the end of the file, rather than grepping for “dovecot”?

Also, is there any difference if you connect via IMAP rather than POP?

-Eric

Ok, an update…

Using as username: domain it worked… for the domain@domain.tld account (the main webmin account)…

So, what am I missing for the other user!?

IMAP is the same…

Here’s what shows up “new”…

Sep 16 17:15:03 stock dovecot: pop3-login: Login: user=, method=PLAIN, rip=XXXXXX, lip=XXXXXX Sep 16 17:15:03 stock dovecot: POP3(domain): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0 Sep 16 17:16:23 stock dovecot: imap-login: Aborted login (2 authentication attempts): user=, method=PLAIN, rip=XXXXXX, lip=XXXXXX

I confess it’s a bit frustrating…

You can verify in “Edit Mail and FTP Users” what the actual account name is, where it says “IMAP/FTP login”.

However, if it works to log in via Usermin, it should certainly work from a desktop client.

So you tried the domain@domain.tld account, and that worked – that’s great – can you use the same email client to test the other account, just changing the username and password?

-Eric

Ok… typical PEBKAC…

I just noticed the email user wasn’t user.domain.tld but user.domain only…

Sorry for wasting your time.

I’d like to know, though, if and how it’s possible to create user@domain.tld usernames for emails.

I’m going to create a new topic about my postfix issue (I’ve browsed the forums, google, etc. but nothing seems to really work for me)

I’d like to know, though, if and how it’s possible to create user@domain.tld usernames for emails.

Yup, take a look in System Settings -> Server Templates -> Default -> Mail for Domain – you can tweak “Format for usernames that include domain”.

Be sure to read the “Help” text for that option though, as there are some caveats in doing so.

-Eric

Thank you so much, that seems to have worked just fine :slight_smile:

Howdy,

Take a peek in /etc/dovecot/dovecot.conf… do you see a mail_location line in there? It should be set, with something like this:

mail_location = maildir:~/Maildir

After setting that, you can restart Dovecot by running:

/etc/init.d/dovecot restart