DBI connect failed?

OS type and version Ubuntu Linux 20.04.6
Webmin version 2.021
Usermin version 1.861
Virtualmin version 7.7
Theme version 20.21
Package updates All installed packages are up to date

So just added a new VS to an existing box (done that before - and it has other VS working OK) Website added with LE and all working OK.
As usual I then add myself as an email account withe Email+FTP a Forward and access to MariaDb then :exploding_head: I get this Error

Any Ideas?

A little more digging and somehow somewhere the MariaDb has stopped working without any warning! and will not restart!

what is the output from

sudo service mysql status


“MariaDB server is down”

I have already tried to restart without success - it even looks like it has vanished. this is a new VS on an old box so no backup yet (just a morning’s work gone if I start over from yesterday

there must be something more than that … I don’t remember the results of the command I sent you responding in that way … that’s a new one one me

Is the problem still there? If yes, please use systemctl restart mariadb and then systemctl status mariadb . Then the current reason why the start failed will be in the output. We can then go over it. And then search in /var/log/mysql/error.log and /var/log/syslog .

Well having tried just about everything it was too important to delay any longer
So I restored the original box from an image backup - All well and the important VS back working though probably a day lost (no more complaints so far)
rather than go through the same nightmare I spun up a new box, installed Virtualmin and then added the VS domain and users. All now working ready to upload the website.

I cannot figure out why MariaDB was blasted off the system or why I could not reinstall it but guess that’s life.

I guess you added ssl to maria … this does make it fail on Ubuntu (ubuntu uses an older version of maria) … I could have verified that from the output of the command I asked you to post


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.