DAV not working

DAV is unreliable, (actually logged in once) and is normally not working at all. Even with a commercial client.

Server is Fedora Core 3

I check httpd.conf and it looks like it is configured right. I made no changes to it. All hosts are pointing to the domainname/dav for the dav directory.

I ran rpm -q mod_dav_svn and the reply was mod_dav_svn-1.2.1-0.1.1.fc3.rf. Is this correct?

Thanks,

Howard.

Hey Howard,

What’s in the access log for that domain when you try to login?

Thanks for your reply,

I just did a login on a virtual server helvawebhost.net. I checked the access_log file, and there was no entry.

Here is another from a domain that works sometimes, but failed this time:

65.111.170.155 - - [[07/Oct/2006:23:30:02 -0400]] "HEAD / HTTP/1.0" 200 -
68.232.221.26 - - [[07/Oct/2006:23:33:27 -0400]] "OPTIONS / HTTP/1.1" 200 -
68.232.221.26 - - [[07/Oct/2006:23:33:27 -0400]] "PROPFIND /dav HTTP/1.1" 401 483
65.111.170.155 - - [[07/Oct/2006:23:35:03 -0400]] "HEAD / HTTP/1.0" 200 -
68.232.221.26 - - [[07/Oct/2006:23:35:14 -0400]] "PROPFIND /dav HTTP/1.1" 401 483
68.232.221.26 - - [[07/Oct/2006:23:35:14 -0400]] "PROPFIND /dav HTTP/1.1" 401 483
68.232.221.26 - - [[07/Oct/2006:23:35:14 -0400]] "OPTIONS / HTTP/1.1" 200 -
68.232.221.26 - - [[07/Oct/2006:23:35:14 -0400]] "PROPFIND /dav HTTP/1.1" 401 483

Hey Howard,

Strange. Don’t know what to make of that–it looks like it’s either not trying, or only giving errors. Check the error_log, as well.

You can also send over detail for the system via email and I’ll see if I can spot/resolve the trouble.

How do I send over the info you need, and exactly what is the info you need?

Hey Howard,

You can email it to me at joe@virtualmin.com.

I’ll need the root password (or a sudo capable user account) and the address of the server.

Hey Howard,

As I noted in email, I’ve been able to successfully upload/download files via DAV on your system…not sure what’s going wrong when you try. I was using the cadaver Open Source DAV client to test uploading files, and I also tested read access using Firefox, both of which worked fine.