Database connection failed : DBI connect failed : Access denied for user

I contacted Virtualmin Pro suppory by mistake, however they very kindly provided me with some support.

I’ve since tired the below and based on the below instructions the mysql password is it using is not listed (wonder if this is the problem)?

Below is my problem and first response from the VM team:

OS: Debian Wheezy
For some reason i am getting access denied for my account.

exec summary:

mysql itself is working
databases currently connected and are ok.
can view and set permissions on databases ok, can even exec sql if needed
using the account details locally via ssh works fine (msql -u [account] -p)
What /seems/ to be the issue is that for whatever reason my virtual server cannot talk to a database (even created a new one, then imported it to be managed by my virtual server), it just tells me access denied.

All I am trying to do is install roundcube via installs scripts.

Found… in cache …

Configuring webserver PHP settings … … already done. Now installing RoundCube version 0.9.5 … Database connection failed : DBI connect failed : Access denied for user ‘REMOVED’@‘localhost’ (using password: YES) 1376. … failed! See the error message above for the reason why.

Is there anyway reset the password it thinks it needs to use?

The virtual server is currently running my forum on it, so I’m cautious about changing passwords and losing database connectivity (although, all i think that will happen is ill loose the ability to manage, long as I don’t change my database permissions). But I’m no expert so i don’t want to make changes without fully understanding the finite details.

Any assistance would be appreciated. Even if its just to call me an idiot :smiley:

Hope the above makes sense

Response from VM Support:
Howdy – changing the database password for that particular domain would be a quick and easy way to resolve that.

Alternatively, if you just wanted to update what Virtualmin though was the password, there are a set of files in /etc/webmin/virtual-server/domains/ – each file represents the domain ID of a given domain on your system.

You can see the domain names assigned to each file by going into that dir, and grepping for the text “dom=”.

Once you find that, you can look for the text “mysql_pass”, which contains the MySQL password.

Remember though that the Support area here is for folks using Virtualmin Pro – if you’re using Virtualmin GPL, you’d want to ask questions in the Forums. We monitor those, along with lots of wonderful folks in the community. Thanks!


Hmm, that’s an odd one! I’m not sure how that password managed to get out of sync.

What if you just reset the database password, does that help? You can do that by going into Edit Databases -> Passwords.

After setting that, are you then able to install RoundCube?


Hi Andre, thanks for getting back to me again.

Its probably a fairly simple fix, but what concerns me the most is breaking any databases that i have already configured that provide functions. If i make this change (and for some reason it causes an issue, no biggie to fix) the only problem being is if i end up locking myself out.

I would have said it was something to do with the password but since i can edit/delete/create databases and assign permissions using that i account… i just dont get it? :frowning:

It must be something i dont fully understand.

Does each Virtual Server have its own “rootpass” so to speak which allows me to create databases and assign passwords to those?

Obviously there is the default Mysqlroot password (which i have and have tested it works!).