Dashboard shows no more system information + let's encrpypt option gone?!

SYSTEM INFORMATION
OS type and version Almalinux 9
Webmin version latest
Virtualmin version latest
Related packages /

Hi a few days ago my server crashed. After a reboot all sites are up again but Virtualmin is having some issues.

  • The dashboard no longer shows any info, only a message box “Virtualmin’s configuration has not been checked since it was last updated. Click the button below to verify it now.”. When I run the “re-check and refresh configuration” it fails with message The feature Administration user cannot be disabled, as it is used by the following virtual servers : [list of my sites]
    … your system is not ready for use by Virtualmin"
  • Every hour I receive a message from the system that it has removed and created a Let’s Encrypt DNS record for myserver.mydomain.om
  • When I went to the domain-config I was presented with the first run wizard again but with (almost) all settings reversed to the defaults (eg “use mariadb: no”)
  • there’s no more Let’s Encrypt option in the “Manage Virtual Server” > “Setup SSL Certificate” page

Any advice (aside re-installing the entire vps)?



have unticked this box ?

This could be solved by replacing /etc/webmin/virtual-server/config with /etc/webmin/virtual-server/last-config file.

So last-config is updated when changes are made?

If config check is successful only then last-config is updated.

ah! thanks. Unfortuantely with jim1r’s suggestion I did make a change so the last-config is useless now. Can I copy this over from a different vps or would you suggest against that?

(lesson of today: setup a scheduled backup for the webmin config :man_facepalming: )

I actually ment have you unticked the box as this may have caused the problem … it’s a pain when you have to translate everything you write

I didn’t untick it but most options were unchecked. But -kudos to Ilia!- the config file misses a few hundred lines (290 while a file from a different server has 485). Figures.

Well, it depends. It may work though.

Is this on bare hardware or are you using a VPS at a hosted location? You could be experiencing disk or other hardware failure. I’d do some basic hardware checks. SMART is a good place to start.

That’s a hosted VPS.
Anyway replacing the config-file from another host (and updating relevant entries like hostname & ip addresses) worked out!

Thanks Ilja for pointing me in the right direction!

You’re welcome! I’m glad you managed to fix it!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.