csf error

hello - i clicked the csf upgrade option i received this morning, and now csf has stopped loading in webmin browser window.

csf CLI works fine.

it appears the problem is in the new csf.js file, i reported it here:

https://forum.configserver.com/viewtopic.php?f=6&t=10594&p=28979

workaround from csf forum reply:

In the meantime, try setting STYLE_CUSTOM = “0” in /etc/csf/csf.conf as that should disable the themes interference with the UI.

Thank you edwardsmarkf - this worked for me after CSF upgraded to 11.05.

i am on 11.05 and i still see this error. changing the STYLE_CUSTOM to zero gets around it.

the error seems to be in /extensions/csf/csf.min.js - and when i pretty-print it, it shows at line 280:

, O = $(‘pre:contains(“csf:”)’).text().match(/((?:(\d+).)?(?:(\d+).)?(*|\d+))$/)[0] || “9.xx”;

the end of it is highlighted: [0] || “9.xx”;

edit: added it here: https://github.com/authentic-theme/authentic-theme/issues/900

I get the blank page (loading) when I try and access CSF. If I change my theme from Authentic to Virtualmin Framed Theme it loads properly.
This must have occurred when the Authentic theme updated. I am currently on 18.49-9 and the problem still exists (I think it was happening on the previous version.)

  • Operating system CentOS Linux 7.4.1708
  • Webmin version 1.860
  • Usermin version 1.721
  • Virtualmin version 6.01
  • Theme version Authentic Theme 18.49-9
  • Firewall version ConfigServer Security & Firewall 11.05
Thanks for that link since it clarifies the situation.

I force installed the latest beta of the Authentic Theme and now it works.
According to https://github.com/authentic-theme/authentic-theme/issues/900 updating the theme to any new version should solver the issue.

This problem was solved with newest theme and webmin virtualmin updates at our BOX. :wink: