Creating a Sub-Server Help

I follow the simple steps here: to create a sub-server and I get a ‘Server not found’ message. Any ideas? thx guys


Where is the nameserver for this particular domain… is it hosted on your server? Or at a third party?

If the nameserver is hosted at a third party, you’d need to setup DNS records for it at that third party.


I did add a sub-Server like two weeks ago, and it all worked fine, without any new steps other than the ones on the above instructions. I purchased my domain name from namecheap, sorry for my igonorance but I am not sure what u mean when u ask if the nameservers are host on a 3rd party server. I do know that when my ISP IP changes, I do have to update the IP at namecheap too. And that’s the only time I have to go to namecheap. But as I said before, I added a sub-server before, without any problems and without going to namecheap.

Sounds like you are using your server as DNS server also.
Also sounds like you are having this server at home. How is your router set up? Does it contact your server as first dns server?
Does your ISP allow you to use ports from 1 - 1024?

My setup is ( I wish we could have this info on like a signature so everyone know the specific syste one has ):
Home Server with Ubuntu 10.04
Virtualmin 3.99
I am able to use those ports (exept for the mail port)
I have forward port: 10000, 443, 80, 21
I use namecheap for my domain name
It is a home server ( personal computer )
I do think it does contact my server as the first DNS server cos when my IP I have to manually update it at namecheap
Yes I am allow to use port 1 - 1024
I have the router setup as DMZ Host and Static NAT


Are we talking about a TLD or subdomain?
When you go to Webmin => Servers => Bind server does your Top Level Domain show? And if you are trying to setup a subdomain, open de TLD and see if the subdomain is also in there.

From where do you try to see the subdomain?

  • From the server
  • From a different system in your LAN
  • From outside

Which application tells you “Server not found”

Can you try to ping to it and also try to ping to the IP if you setup a specific IP.

I’m talking about a subdomain ( is my TLD and is what I have setup as my subserver (subdomain). I did manage to add this same subdomain before and all I did was add a subserver and left all default settings and it worked, and for a dumm reason I decided to delete it ( can’t even remember why).

FYI I’m in the mobile phone templete cos I’m not near my computer.

When I go to Bind DNS Server only the TLD is there not the subdomain.
Yes the subdomain does shows under the TLD
I have try to access the from the FF browser which tell me server not found
I did not setup a different IP, as I created the subdomain I left all settings as default


If you go into Edit Virtual Server -> Enabled Features for this particular sub-domain, is the BIND DNS Domain feature enabled?


That option is not present there

Hmm, are you logged in as the root user? The root user should be able to see the various available features for the Virtual Servers.


Nop, no BIND Server option there not even in for the TLD. Here is what’s there

DNS domain
Mail for domain
Apache webside
SSL webside
Spam …
Virus …
DAV Login

I’m sorry, I got the feature name wrong :slight_smile:

The feature you want is “DNS Domain”, and not the “BIND DNS Domain” that I mentioned above.

So if you go into Edit Virtual Server -> Enabled Features, is DNS Domain enabled?


Yes I do thx have that enable


Manage to add the sub-server after a clean install. Most of been a bad configuration tina some where.