Created subserver, but mobile devices can't reach it

Here’s something kinda weird.

I created beta.deannazandt.com using Virtualmin (4.07), and bringing it up on my laptop browser (OSX 10.9.4, Chrome), it works just fine.

However, when I try to open the URL on either my HTC One or my iPad, I get: “This webpage is not available.” This happens whether or not I’m connected to my home wifi, or if I connect them to the cellular data network.

I double-checked my hosts file on my laptop to make sure I hadn’t done any funky redirects. Only contents are the default:
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost

DNS is managed by Amazon’s Route 53 service; there is a record there for this domain:

beta.deannazandt.com. CNAME 74.50.60.88

Edit: Also did a dig, returning correct results:

; <<>> DiG 9.8.3-P1 <<>> beta.deannazandt.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 11468
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;beta.deannazandt.com. IN A

;; ANSWER SECTION:
beta.deannazandt.com. 299 IN CNAME 74.50.60.88.

;; AUTHORITY SECTION:
. 1799 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2014073001 1800 900 604800 86400

Any ideas?

cheers
dz

CNAME DNS records are for mapping a hostname to another hostname. To map it to an IP address, like you did, you’ll want an A DNS record.

Good grief. That worked-- thank you!

You’re welcome! :slight_smile: