Create New Virtual Server - "domain validation failed" for Lets Encrypt (but maunual requesting it works fine)

I guess i am not sure what you mean. You mean for the DNS configuration for Virtualmin?

Based on my understanding…that setup would check to see if is a resolvable address on the internet. it wouldn’t would it? it it would be the virtualmin server i am setting up?

Let’s say you own

When you run the post install wizard you enter or something along those lines as the primary. But the part has to be resolvable. Otherwise, you’re going to have issues with LetsEncrypt and you’ll probably wind up having to manually install your SSL certificates.

great thanks. i do own the domain name in question. i dont mind reinstalling virtualmin at this point…its more of a self paced learning process for me at this point. i dont plan on hosting peoples businesses sites until i learn more. virtualmin is just a beast i was not expecting :slight_smile:

You don’t have to reinstall it. You just need to configure it properly.

You can rerun the post install wizard.

Just BEFORE YOU DO, make sure you have the A record for the domain names entered in your Cloudflare or LetsEncrypt will never make it to your server in order to resolve the domain.

So you should have in your DNS up at Cloudflare: ---- pointed to your servers IP ---- pointed to your servers IP.

After that, any domain or subdomain you create in Virtualmin, you’ll have to go back up to Cloudflare and enter the DNS record and point it to your servers IP.

1 Like

Really appreciate your patience with me. I am a very hands on learner, so i dont MIND reinstalling. Its a hobby for me now. I work IT in my day job, but hope to one day make a side gig IT service business for people who cant afford the bigger MSPs in the area haha

1 Like

No problem. We all stumble around in the dark at first. That’s the good thing about this place though: there’s a bunch of people with a whole lot of knowledge that can help you get through just about anything.

And if that doesn’t work out there are some real pros around here that can fix it on the cheap. So there’s always that.

I will probably end up getting Pro to help with some things like Nextcloud and Wordpress (im using a template now WordPress Server Template on Virtualmin - YouTube) and maybe ticket support if i need it :slight_smile:

Please don’t watch ANY Videos that aren’t done by Virtuamin’s crew. Most of them are wrong and complete junk.

Wordpress is simple. It’s in the install scripts. Click it, go to the bottom and hit install. Just make sure you select “at top level” in the install dialogue if you don’t want your site to have the address.

1 Like

It is worth adding that Virtualmin Pro allows you to set up CloudFlare as a DNS provider. You may find that makes management a bit easier.


I’m back…with a new fun issue…i jsut got a new domain…and went to create…the ssl at creation faield, and then i went in after to do it…i get this:

Validating configuration for
… errors were found, which will prevent Let’s Encrypt from issuing a certificate :

Apache website : An IPv6 DNS record with address 2606:4700:3032::ac43:a1ab exists, but this virtual server does not have IPv6 enabled
OS type and version Debian 10
Virtualmin version 7.1

I’m pretty new with Virtualmin and believe the issue I am running into creating new sites on my Virtualmin box is very similar.

I was having the creation fail indicating Let’s Encrypt not being able to resolve admin.domain.tld and webmail.domain.tld. I added those hosts to the domain’s A records and that solved the problem.

That being said, I normally run DNS, email and websites on separate boxes. While I (think I) understand there is a Usermin management interface available that uses the admin host, I really don’t need it or webmail on my Virtualmin box.

Is there a place in the settings or in a template (I roamed through those and did not see it) where I can remove the “admin” and/or “webmail” hosts so Let’s Encrypt does not fail without them?


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.