cpanel to virtualmin immigration issue

about 300 MB
I backup my site from cpanel ( Full backup the backup you normally use to move to a new user )
I go to virtualmin and to migrate, I have uploaded the tar.gz to a local folder
inside my virtualmin I am migrating
it is validating migration file…
but it gives this error

validation failed : Not a cPanel tar.gz file : Un-archive command failed : /bin/tar:

…Archive contains obsolescent base-64 headers
---------------------------Cannot write: No space left on device /bin/tar: Skipping to next header /bin/tar

--------------------------------Cannot write: No space left on device /bin/tar: Error exit delayed from previous errors

some the errors I see are the above

I don’t know much about the cPanel backups, but are you using a full backup from your cPanel system?

Also, it’s saying “Cannot write: No space left on device” – are you sure that there’s enough space on your Virtualmin server for that backup… both in /tmp (which Virtualmin uses as a temp directory), as well as in /home?

-Eric

Eric you know what you are talking about I love you guy perhpas it is because of /temp file
to make it secure I made some changes what should I do now?

Well, how about this… can you log into your server as root, and run the command “mount”?

That should show what settings it was mounted with. Then we can figure out if any of those are causing trouble :slight_smile:

-Eric

Hi thanks for help:

this is the result

/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw,grpquota,usrquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/xvda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/var/tempFS on /tmp type ext3 (rw,noexec,nosuid,loop=/dev/loop0)
none on /dev/shm type tmpfs (rw,noexec,nosuid)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

Ahh, yeah, the noexec flag on /tmp might be causing trouble.

One option would be to remove the noexec flag.

Another option would be to change Virtualmin’s temp directory so that it uses something other than /tmp.

You can change Virtualmin’s temp dir by going into Webmin -> Webmin -> Webmin Configuration -> Advanced Options, and you can change “Temporary files directory”. Using /var/tmp might be a decent place to put those.

-Eric