CPANEL migrations Problems again

Hello again,

We are migrating sites from cpanel.

after migrating a couple of few of them, we decided to check the option
"Validate Virtual Servers"

and we got a lot of errors

Beginning validation of selected virtual servers. Any problems found will be shown in red …

x.com.pt
Mail for domain : Home directory /usr/local/apache/domlogs for user wwwinoq_logs is owned by wwwmerv_logs
xpto.pt
Mail for domain : Home directory /usr/local/apache/domlogs for user gmacimob_logs is owned by wwwmerv_logs
yxz.net
Mail for domain : Home directory /home/wwwjp/public_html/mags for user mags is owned by root


how to solve this??
thanks

Plus… we are applying templates to accounts after being migrated and… the configuration is not being applyed correctly.

meaning… the quotas and features options are not beeing applyed.

please advise.
thanks

For the users with _logs at the end of their names, I think you can ignore these and even remove those users, as I presume that they are some cPanel internal users that are not needed in Virtualmin. In fact, it is a bug that they were even migrated at all … I will prevent this in the next release.

For the other users (like mags below), you can fix the ownership by running :

chown -R mags: /home/wwwjp/public_html/mags

That is a rather odd home directory for the user though … does it actually even exist?

Templates do not effect quotas when they are changed - if you want to make mass changes to domains, click on List Virtual Servers, select the ones you want to modify, click the Update Selected button, make some modifications in the ‘Quota and bandwidth changes’ section and click ‘Update Servers’.

give me an email so i can give you acces to it

by the way… no tutorial on that on the website… :smiley:

My email is jcameron@webmin.com .
Let me know what specific fixes / changes you need…

Hello again,

after submiting /enforcing changes using mass update to the accounts, we got this:

2829 imomaste 25 0 60248 18m 988 R 7.0 1.0 0:07.74 clamscan
2819 angetito 25 0 78072 36m 988 R 6.6 1.9 0:10.39 clamscan
2794 ecoalcan 25 0 77944 35m 988 R 6.3 1.9 0:09.69 clamscan
2911 e-servic 25 0 50544 8764 984 R 5.0 0.5 0:04.79 clamscan
2780 graudesu 25 0 78076 35m 988 R 3.3 1.9 0:10.29 clamscan
2789 herdaded 25 0 77944 35m 988 R 3.3 1.9 0:09.59 clamscan
2790 lusolabs 25 0 77940 35m 988 R 3.3 1.9 0:09.24 clamscan
2855 beyond-o 25 0 50812 9072 984 R 3.3 0.5 0:06.89 clamscan
2875 colors-p 25 0 50808 9008 984 R 3.3 0.5 0:06.50 clamscan
2883 servirth 25 0 50812 9064 984 R 3.3 0.5 0:06.89 clamscan
2906 dev-it 25 0 50548 8744 984 R 3.3 0.5 0:04.59 clamscan
2909 aloeonli 25 0 50544 8740 984 R 3.3 0.5 0:04.60 clamscan
2922 piso2 25 0 50812 8964 984 R 3.3 0.5 0:06.09 clamscan
2931 wwwatea 25 0 50808 8956 984 R 3.3 0.5 0:06.09 clamscan
2941 factoria 25 0 50680 8828 984 R 3.3 0.5 0:05.24 clamscan
2944 dancaeco 25 0 50676 8828 984 R 3.3 0.5 0:05.19 clamscan
2947 fundacao 25 0 50676 8840 984 R 3.3 0.5 0:05.30 clamscan
2954 ateaofim 25 0 50544 8692 984 R 3.3 0.5 0:04.39 clamscan
2981 remoport 25 0 50544 8700 984 R 3.3 0.5 0:04.40 clamscan
2983 artop 25 0 50548 8696 984 R 3.3 0.5 0:04.39 clamscan
2985 cursorat 25 0 50544 8700 984 R 3.3 0.5 0:04.39 clamscan
2990 503 25 0 50412 8676 984 R 3.3 0.4 0:04.30 clamscan
2994 geral.lu 25 0 50544 8684 984 R 3.3 0.5 0:04.29 clamscan
3072 503 25 0 49888 8148 984 R 3.3 0.4 0:01.89 clamscan
3137 wwwatea 25 0 49488 7720 984 R 3.3 0.4 0:00.59 clamscan
3153 root 18 0 51480 6936 3172 R 3.3 0.4 0:00.60 rpmq
474 root 21 -4 12564 416 340 R 1.3 0.0 0:00.47 udevd
2553 dovecot 15 0 27920 696 632 S 0.3 0.0 0:00.01 pop3-login
2557 dovecot 15 0 27928 692 632 S 0.3 0.0 0:00.01 imap-login

MAjor CPU usage now, after this step… Is this normal? by the way, we are using/configuring clamav as stand alone program, and not server daemon. Is this a good choice? or not?

thanks

we decided to take off virus filtering from the accounts… the server is getting to slow.

another strange thing is…

[root@hosting ~]# service httpd start
Starting httpd: httpd: Syntax error on line 2905 of /etc/httpd/conf/httpd.conf: Expected </Directory> but saw </VirtualHost>
[FAILED]
[root@hosting ~]#

the apache does not start :S

thanks

the migration went wrong. we fixed the httpd.conf with VI. and worked out.

strange thing is… mysql Databases are not being migrated…

can you help?

thanks

If you get a lot of email, the stand-alone clamscan scanner may not be able to cope, as it starts a new instance and reads the whole virus DB for each incoming message. The solution is to setup clamd, and then configure all your Virtualmin domains to use clamdscan instead. The exact process for setting up clamd varies from distro to distro though, and is not yet automated by Virtualmin.

Which distro are you running there?