cPanel migration - no files

I have used the cPanel migration with mixed success.

The mySQL databases seem to migrate correctly, but no files are being copied to public_html and no e-mail addresses are created.

With one of my accounts I did the migration, I then manually copied all the Web site files into public_html, and the programs connected to and used data from the MySQL database successfully.

Does anyone have any idea what might be going wrong?

Operating system CentOS Linux 5.2
Webmin version 1.441
Virtualmin version 3.64.gpl GPL

Other server
cPanel 11.24.4-R32603
WHM 11.24.2 - X 3.9
CENTOS 4.7 i686 on standard

The messages I get after migration are below:

  Checking for cPanel features ..
  .. found Home directory, Administration user, Apache website, Webmin login, BIND DNS domain, Mail for domain.

  Checking for clashes and dependencies ..
  .. all OK

  Creating initial virtual server ..
        Creating administration group martyn ..
        .. done

        Creating administration user martyn ..
        .. done

        Creating aliases for administration user ..
        .. done

        Adding administration user to groups ..
        .. done

        Creating home directory ..
        .. done

        Creating mailbox for administration user ..
        .. done

        Adding to email domains list ..
        .. done

        Adding new DNS zone ..
        .. done

        Adding new virtual website ..
        .. done

        Adding Apache user apache to server's group ..
        .. done

        Creating Webmin user ..
        .. done

        Re-starting DNS server ..
        .. done

        Applying web server configuration ..
        .. done

        Re-loading Webmin ..
        .. done

        Saving server details ..
        .. done

  .. done

  Copying home directory to /home/martyn ..
  .. done

  Fixing home directory permissions ..
  .. done

  Re-creating mail users ..
  .. done <b>(migrated 0 mail users)</b>

  Moving server owner's mailbox ..
  .. none exists

  Copying email aliases ..
  .. done (migrated 1 aliases)

  Copying Cron jobs ..
  .. done

  Re-creating FTP users ..
  .. done (created 0 FTP users)

  Applying web server configuration ..
  .. done

Successfully migrated 1 servers. Click here to manage the new server.

This is because of a change to the cpanel backup tool. It is now storing the homedir in a tar archive. It leaves a homedir folder in the backup with nothing in it. The work around that I know of is to extract the backup and untar the homedir.tar back into the homedir folder and then tar the backup and migrate from that.

Looks like upgrading to vmin 3.66 fixes the issue