Could never install Virtualmin on Debian or Ubuntu

I could only install Virtualmin on Centos but never on Debian/Ubuntu.

I followed the steps mentioned on Virtualmin website.

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
Depends: libsys-hostname-long-perl but it is not going to be installed
Depends: libwww-perl but it is not going to be installed
Depends: libnet-dns-perl (>= 0.34) but it is not going to be installed
Depends: libnetaddr-ip-perl but it is not going to be installed
Recommends: libmail-spf-perl but it is not going to be installed
Recommends: re2c but it is not going to be installed
Recommends: libio-socket-inet6-perl but it is not going to be installed
subversion : Depends: libsvn1 (= 1.6.12dfsg-6) but it is not going to be installed
usermin : Depends: libauthen-pam-perl but it is not going to be installed
Depends: libio-pty-perl but it is not going to be installed
Depends: apt-show-versions but it is not going to be installed
webalizer : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed
webmin : Depends: libauthen-pam-perl but it is not going to be installed
Depends: libio-pty-perl but it is not going to be installed
Depends: apt-show-versions but it is not going to be installed

FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

Thanks

Howdy,

Could you attach your /root/virtualmin-install.log file?

That would contain some info we could use for debugging the issue you’re seeing.

Thanks!

-Eric

Here it is

INFO - 2012-12-10 05:40:43 - Started installation log in /root/virtualmin-install.log DEBUG - 2012-12-10 05:40:43 - Install mode: full DEBUG - 2012-12-10 05:40:43 - Product: Virtualmin GPL DEBUG - 2012-12-10 05:40:43 - Virtualmin Meta-Package list: virtualmin-base DEBUG - 2012-12-10 05:40:43 - install.sh version: 1.0.9 INFO - 2012-12-10 05:40:43 - Checking for fully qualified hostname... INFO - 2012-12-10 05:40:43 - Hostname OK: fully qualified as ns1.kannikar.com INFO - 2012-12-10 05:40:43 - Installing serial number and license key into /etc/virtualmin-license INFO - 2012-12-10 05:40:43 - Loading OS selection library... INFO - 2012-12-10 05:40:43 - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded. INFO - 2012-12-10 05:40:43 - Loading OS list... INFO - 2012-12-10 05:40:43 - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded. INFO - 2012-12-10 05:40:43 - Operating system name: Debian Linux INFO - 2012-12-10 05:40:43 - Operating system version: 6.0 INFO - 2012-12-10 05:40:43 - Configuring package manager for Debian Linux 6.0... INFO - 2012-12-10 05:40:43 - Enabling universe repositories, if not already available... INFO - 2012-12-10 05:40:43 - Disabling cdrom repositories... INFO - 2012-12-10 05:40:44 - Cleaning up apt headers and packages, so we can start fresh... INFO - 2012-12-10 05:40:44 - INFO - 2012-12-10 05:40:44 - Download of http://software.virtualmin.com/lib/apt.conf.noninteractive Succeeded. INFO - 2012-12-10 05:40:44 - Installing Webmin and Virtualmin package signing keys... INFO - 2012-12-10 05:40:44 - Download of http://software.virtualmin.com/lib/RPM-GPG-KEY-virtualmin Succeeded. INFO - 2012-12-10 05:40:44 - Download of http://software.virtualmin.com/lib/RPM-GPG-KEY-webmin Succeeded. INFO - 2012-12-10 05:40:45 - OK INFO - 2012-12-10 05:40:45 - OK INFO - 2012-12-10 05:40:47 - Get:1 INFO - 2012-12-10 05:40:47 - Removing Debian standard Webmin package, if they exist... INFO - 2012-12-10 05:40:47 - Removing Debian apache packages... DEBUG - 2012-12-10 05:40:47 - Reading INFO - 2012-12-10 05:40:47 - Installing dependencies using command: /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php5 php5-cgi libgd2-xpm libapache2-mod-php5 php5-mysql Reading package lists... Building dependency tree... Reading state information... libsasl2-2 is already the newest version. sasl2-bin is already the newest version. iptables is already the newest version. procmail is already the newest version. quota is already the newest version. unzip is already the newest version. zip is already the newest version. webmin is already the newest version. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: apache2 : Depends: apache2-mpm-worker (= 2.2.16-6+squeeze10) but it is not going to be installed or apache2-mpm-prefork (= 2.2.16-6+squeeze10) but it is not going to be installed or apache2-mpm-event (= 2.2.16-6+squeeze10) but it is not going to be installed or apache2-mpm-itk (= 2.2.16-6+squeeze10) but it is not going to be installed Depends: apache2.2-common (= 2.2.16-6+squeeze10) but it is not going to be installed apache2-suexec-custom : Depends: apache2.2-common but it is not going to be installed bind9 : Depends: libbind9-60 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: libdns69 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: libisc62 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: libisccc60 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: libisccfg62 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: liblwres60 (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed Depends: bind9utils (= 1:9.7.3.dfsg-1~squeeze8) but 1:9.7.3.dfsg-1~squeeze4 is to be installed clamav : Depends: libclamav6 (>= 0.97.5+dfsg) but it is not going to be installed clamav-daemon : Depends: libclamav6 (>= 0.97.5+dfsg) but it is not going to be installed Depends: libtommath0 but it is not going to be installed clamav-freshclam : Depends: libclamav6 (>= 0.97.5+dfsg) but it is not going to be installed dovecot-common : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed Depends: libpq5 (>= 8.4~0cvs20090328) but it is not going to be installed libapache2-mod-fcgid : Depends: apache2.2-common but it is not going to be installed libapache2-mod-php5 : Depends: libonig2 (>= 5.2.0) but it is not going to be installed Depends: libqdbm14 (>= 1.8.74) but it is not going to be installed Depends: apache2-mpm-prefork (> 2.0.52) but it is not going to be installed or apache2-mpm-itk but it is not going to be installed Depends: apache2.2-common but it is not going to be installed Depends: php5-common (= 5.3.19-1~dotdeb.0) but it is not going to be installed Recommends: php5-cli but it is not going to be installed libapache2-mod-ruby : Depends: libruby1.8 (>= 1.8.7.22) but it is not going to be installed Depends: apache2.2-common but it is not going to be installed Depends: libapache-ruby1.8 (= 1.2.6-2) but it is not going to be installed libapache2-svn : Depends: apache2.2-common but it is not going to be installed Depends: libsvn1 (>= 1.6) but it is not going to be installed libcrypt-ssleay-perl : Depends: liburi-perl but it is not going to be installed libdbd-mysql-perl : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed Depends: libdbi-perl (>= 1.610.90) but it is not going to be installed Depends: perl-dbdabi-94 libdbd-pg-perl : Depends: libpq5 (>= 8.4~0cvs20090328) but it is not going to be installed Depends: libdbi-perl but it is not going to be installed Depends: perl-dbdabi-94 libfcgi-dev : Depends: libfcgi0ldbl (= 2.4.0-8) but it is not going to be installed libgd2-xpm : Depends: libjpeg62 (>= 6b1) but it is not going to be installed Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed Depends: libx11-6 but it is not going to be installed Depends: libxpm4 but it is not going to be installed libpg-perl : Depends: libpq5 (>= 8.3~beta1) but it is not going to be installed libxml-simple-perl : Depends: libxml-namespacesupport-perl (>= 1.04) but it is not going to be installed Depends: libxml-sax-perl but it is not going to be installed Depends: libxml-libxml-perl but it is not going to be installed or libxml-sax-expat-perl but it is not going to be installed mysql-client : Depends: mysql-client-5.5 but it is not going to be installed mysql-server : Depends: mysql-server-5.5 but it is not going to be installed php-pear : Depends: php5-common (>= 5.3.19-1~dotdeb.0) but it is not going to be installed Depends: php5-cli but it is not going to be installed php5 : Depends: php5-common (>= 5.3.19-1~dotdeb.0) but it is not going to be installed php5-cgi : Depends: libonig2 (>= 5.2.0) but it is not going to be installed Depends: libqdbm14 (>= 1.8.74) but it is not going to be installed Depends: php5-common (= 5.3.19-1~dotdeb.0) but it is not going to be installed php5-mysql : Depends: php5-common (= 5.3.19-1~dotdeb.0) but it is not going to be installed postfix : Conflicts: mail-transport-agent postgresql : Depends: postgresql-8.4 but it is not going to be installed postgresql-client : Depends: postgresql-client-8.4 but it is not going to be installed python : Depends: python-minimal (= 2.6.6-3+squeeze7) but 2.6.6-3+squeeze6 is to be installed ri : Depends: ri1.8 but it is not going to be installed rmail : Conflicts: postfix but 2.7.1-1+squeeze1 is to be installed ruby : Depends: ruby1.8 but it is not going to be installed sendmail-bin : Conflicts: mail-transport-agent spamassassin : Depends: libhtml-parser-perl (>= 3.43) but it is not going to be installed Depends: libdigest-sha1-perl but it is not going to be installed Depends: libsocket6-perl but it is not going to be installed Depends: libsys-hostname-long-perl but it is not going to be installed Depends: libwww-perl but it is not going to be installed Depends: libnet-dns-perl (>= 0.34) but it is not going to be installed Depends: libnetaddr-ip-perl but it is not going to be installed Recommends: libmail-spf-perl but it is not going to be installed Recommends: re2c but it is not going to be installed Recommends: libio-socket-inet6-perl but it is not going to be installed subversion : Depends: libsvn1 (= 1.6.12dfsg-6) but it is not going to be installed usermin : Depends: libauthen-pam-perl but it is not going to be installed Depends: libio-pty-perl but it is not going to be installed Depends: apt-show-versions but it is not going to be installed webalizer : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed webmin : Depends: libauthen-pam-perl but it is not going to be installed Depends: libio-pty-perl but it is not going to be installed Depends: apt-show-versions but it is not going to be installed FATAL - 2012-12-10 05:40:48 - Fatal Error Occurred: Something went wrong during installation: 0 FATAL - 2012-12-10 05:40:48 - Cannot continue installation. FATAL - 2012-12-10 05:40:48 - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - 2012-12-10 05:40:48 - re-attempted after any problems have been resolved. FATAL - 2012-12-10 05:40:48 - Removing temporary directory and files. FATAL - 2012-12-10 05:40:48 - If you are unsure of what went wrong, you may wish to review the log FATAL - 2012-12-10 05:40:48 - in /root/virtualmin-install.log

Ah, it looks like you have some third party repositories enabled, which can cause problems like what you’re seeing.

Our recommendation would be to perform your installation using a fresh install, with no third party repositories enabled. Third party repositories can cause package conflicts and other unexpected problems.

If you can, I’d suggest performing a fresh install of your OS, followed by attempting the Virtualmin installation again.

Alternatively, you could always try just disabling your third party repositories, and seeing if it’s able to complete the install at that point.

-Eric

I am always trying to fresh install my OS at VPS.

Can you post me the sequence of commands to perform Webmin and Virtualmin installation on a fresh install of Debian 6 or Ubuntu 12.04.

Following the Webmin/Virtualmin website didn’t work for me but perfectly working on CentOS.

Thanks

Well, the output you listed above makes reference to the dotdeb repository, which isn’t enabled in a fresh install of Ubuntu or Debian.

Are you by chance using a VPS image? If so, it’s possible your VPS provider is setting up a third party repository for you by default.

What is the output of this command:

find /etc/apt | xargs grep dotdeb

And this command:

cat /etc/apt/sources.list

For find /etc/apt | xargs grep dotdeb

/etc/apt/sources.list:deb http://packages.dotdeb.org squeeze all /etc/apt/sources.list:deb-src http://packages.dotdeb.org squeeze all Binary file /etc/apt/trusted.gpg~ matches Binary file /etc/apt/trusted.gpg matches /etc/apt/sources.liste:deb http://packages.dotdeb.org squeeze all /etc/apt/sources.liste:deb-src http://packages.dotdeb.org squeeze all

For cat /etc/apt/sources.list

deb http://ftp.debian.org/debian squeeze main contrib non-free deb http://security.debian.org squeeze/updates main contrib non-free

deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

Yeah, that’s a non-standard repository setup in your sources.list file… dotdeb is a third party repo, not one that comes with Debian or Ubuntu.

That was either enabled after the distro was installed, or it may have been setup by your provider if they built your distro image.

You could always try commenting out the dotdeb repo from your sources.list file and re-attempting the install.

However, if there’s already dotdeb packages installed on your system, you may continue to see problems, and you may need to start with a fresh install of your distro – and then just make sure that dotdeb is disabled before performing any package installs.

-Eric