Constantly increasing ram usage?

Constantly increasing ram usage

The system is constantly running php-cgi, is there a problem?

OS type and version CENTOS 7
Webmin version 1.984
Virtualmin version 6.17
Related packages SUGGESTED

Question: you wouldn’t be running Apache and Nginx at the same time, would you?

no i just use apache. I want to use Apache

@hakankaya any reasons for you running your php from …/otp?

That’s where PHP 7 is on an old RHEL or CentOS system.

@Joe thanks for update. I do not use rhel or centos so my knowhow on this os is more then limited.


Check this article out I wrote… This may save your bacon (as we are stereotyped as saying in Canada).


That’s a.nice writeup on PHP-FPM optimization but @hakankaya, you are having issues with php-cgi and so you must tweak the parameters that apply to that.

@calport @hakankaya,

My bad, I misread the screenshot.

Maybe it’s because of the setting here.
How Should This Setting Be?


Set PHP_FCGI_MAX_REQUESTS to a low value so that php-cgi processes are recycled quickly, more of a workaround. Do you use any cache service?

Backup everything and try:


I dont know if you are running a high powered script with XXX users. Restart apache after editing above and test.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.