conflict with virtualmin and kaltura

I’ve spent the last few days trying to get kaltura ( installed onto my Debian 6x system running virtualmin/webmin.

I had no problem at all actually installing kaltura, but in the end I would only get a 404 when trying to reach the kaltura admin start page.

At that point, I had a sysadmin friend of mine jump in and take a look. After a few hours of digging around he came to the point where it was determined that something with virtualmin is causing a problem.

I am NOT a sysadmin in any fashion, just a poor bloke with a server who is trying his darndest to learn this stuff, so I am sure my terminology may be off at times.

If it’s ok, I’ll post in what he told me via skype to see if it makes any sense to someone here as to what I should be trying.

I can say that our setup was to create a sub-domain virtualhost, and use that address during the install of kaltura.

Here is the conversation:

ok it works but doesn’t you didn’t have a catch all in bind9 for subdomains
I added the kultra or whatever and now pings and works BUT now you have virtual server issue

it works when I turn off other sites you never created the subdomain I can do this
create a virtual subdomain for it so I can attach the info to the file
please add it it needs it own unique IP virtual only way you have some interface handling it and I cant overide or it kills all other sites.

it is messing everything I am trying to do up
so your on your own
the kaltura works I can verify this by blocking your virtual admin software stuff it shows start page etc so you just need to figure out virtualadmin stuff
i tried adding subdomain but it is subdomain for files not for virtual host override it doesn’t even add a URL for it
may want to create a new site and do it that way it is nothing wrong
not sure you understand it is 100% the virtual stuff it is all a ok when you bypass that stuff want to see? it kills your other sites

when it includes sites-enabled/ it kills your stuff
let me see if there is anything I can see in there do you use default port 80 localhost for anything
phpmyadmin or anything ip/phpmyadmin or anything like that in the var/www

just need to get the file integrated into vritual admin or lost I dont know virtual admin but when i try to do it normaly it works within linux

Well that is the pertinent part. I was able to see kaltura working perfectly when he did it manually, but that killed all the sites on the server, which we couldn’t keep.

Just in case it helps, here is the installation instructions for kaltura. Maybe something will stand out?

also, kaltura generates a .conf file which as part of the installation instructions we do an include in the apache conf file.

Here is that file
*I changed the ip and hostname but other than that it is what kaltura uses.

I really LOVE virtualmin, and as a rookie I’d be lost without it, so I would really love to be able to keep it and also use the kaltura engine.

Can anyone point to what we might be doing wrong with kaltura and virtualmin together?

thanks so much for taking the time to read such a long post!


Well, posting rants of folks calling “Virtual Admin” stupid isn’t always the best way to get help :slight_smile:

However, the thing to remember is that Virtualmin is designed for shared hosting, and it configures Apache with some defaults for you. Those defaults are different than a typical server, so your friend may be making assumptions about how things should work that aren’t the case.

For example – when you want a new website on a Virtualmin system, you’d want to create a new Virtual Server from within Virtualmin – and that’ll setup web space for you in /home/USERNAME/public_html.

Then, if you have a web application you want to use – that web application would need to go into that directory.

Running websites out of /var/www won’t work, you’d need to put them in the directory in /home that you create from within Virtualmin.

I see that Kaltura has an installation script – does it give you an opportunity to specify where it should be installed?

There’s also different PHP Execution Modes you can try.

By default, it’ll use FCGID for running PHP code.

However, if that doesn’t work for you, you could also try CGI or mod_php.

To configure those, you can go into Server Configuration -> Website Options.


Sorry, honestly I did not even notice the rant in what I had pasted and I went up and removed that line. In fact I LOVE virtualmin as I noted in my post.

To answer your questions.
Yes kaltura does allow me to choose the installation directory during the install. In one of my dozens of attempts to get it working, I did actually install kaltura into the public_html directory. I had the same 404 problem.

If you read the kaltura config that I linked to, it defines the public directory where kaltura was installed. My thought process is that virtualmin would read the kaltura config file as we are using an include statement in the apache config to tell virtualmin where the public dir is located.

Now what I had done was to create a virtual sub-server for my subdomain for the kaltura install.

One thought I had was I wonder if I should actually replace the config file created by virtualmin for that sub-server site with the kaltura one instead of simply including it… I should probably try that.

I do know that kaltura is installed perfectly itself, as if my friend bypasses the virtualmin system we were indeed able to see the admin panel at It is only if he turns back on the virtualmin system that we get the 404 errors.

I don’t think the php has anything to do with it, but I could be wrong.

Can anyone think of a reason why virtualmin seems to be ignoring the kaltura config file for this site?

thanks again. Day 6 and I’m still determined to get this working :slight_smile:

Problem solved:
Here is how I got it working. Posting in hopes to help someone else out in the future.

When installing kaltura, it generates a config file for the virtualhost. You are instructed to add an ‘include’ statement to your apache conf file to include the kaltura conf file.

This causes an issue in that now there are 2 conflicting virtualhost directives. The one added by virtualmin tells visitors where the home directory is and the permissions for htaccess, while the kaltura one gives totally different paths and rules.

What I did was to copy the information from the kaltura config and overwrite the config file from virtualmin.

One extra thing to remember is that the config file from kaltura defines the directory as *:80. This needs to be changed to your virtual ip address so 'replacing 123 with your actual ip address.

Finally kaltura says to add ‘kaltura-hostname-used-during-install’ to the hosts file. This does not work. You need to replace the 127… with the ip address you assigned to the virtual server you created for kaltura.

then restart apache and your good to go.

*One thing I did was to copy over the virtualmin conf file in both ‘sites-enabled, and sites-available’. I am not sure if this was necessary or not, but I did it anyhow.

**finally, I have no idea what would happen if I were to go into my virtualmin panel for the new sub-domain virtualhost and try to save anything. My guess is that it would overwrite my new custom conf file, which of course would be really bad. I don’t know how to stop that from happening, so for now, I will just never ever ever go into virtualmin and make a change to the dns side of my new virtualhost.

If someone has an idea of how to solve that potential issue, I would love to hear it, as would anyone else who ever finds and uses my solution.

Sure hope this helps someone in the future, as this was the most rotten 6 days I have ever had working on this stuff. good luck everyone.

The Kaltura installation appears to be assuming you are running it on a dedicated system; i.e. no other websites and only one user managing it. Virtualmin assumes the opposite; that you will be running lots of websites, with lots of users managing them.

You’ve figured out most of what you need to do to make it all spin nicely. Virtualmin will respect custom directives in the Apache configuration, except where they conflict with what Virtualmin has been configured to managed, so it probably will not overwrite your changes…but, sites-enabled is generally a link to the configuration file in sites-available, rather than being a duplicate of the file. I’m not sure that would cause any problems, but I seem to recall an issue report a while back from someone who was confused about weird behavior from a system that had that problem (he’d done the same thing; manually modified sites-available/domainname.conf and made it into a file rather than a link).

It’s highly recommended you test before putting this in production, so you can know what changes when you use Virtualmin to modify your configuration…someday you’ll forget that you didn’t want to do that, and something might break.

But, one of the reasons you love Virtualmin (even if you don’t know it yet), is that it understands the configuration files it manages in ways that none of its competitors do…so, it does not spew out configuration files from templates; it actually reads them and modifies them based on what you’re telling it to change. It very, very, rarely will break manually modified configurations, except in a few specific areas (IP:port might be one of those areas).