Configuring Net, Packet Write Wait - Broken pipe

OS : Debian 9
Virtualmin : Latest
VPS RAM : 1GB
VPS Core : 1

Hello all,
I bought a new low ram VPS with 1GB RAM for dev. However, when installing Virtualmin I get this error at the final stage.

Do a web or forum search howto change setup part to have more minimal installation

Also before make a swap file…

and take care of settings network and firewall related things

OYEA hmm for DEV then nog good idea having low memory box, while then if errors you don’t know related to low specs… :wink:

1 Like

I found a topic about this issue on a forum

ClientAliveInterval 300
ClientAliveCountMax 2

Gonna try this one and see if it’s help :grinning:

Ok this is interesting

Screen Shot 2021-10-17 at 8.56.14 PM

That is while on port 443:

EDIT THINK MY FAULT HERE sorry: > Dieser Server konnte nicht nachweisen, dass es sich bei ihm um 163.172.162.254 handelt. Das Sicherheitszertifikat stammt von software2.virtualmin.com . but on dns it also has DNS-naam
software.virtualmin.com

So could also be on your site that can not handle that ssl encryption , or the port there , curl or whatever used to get the data

Check to be sure it i from right ip resolving from your box

EDIT THINK MY FAULT HERE:
That error i quoted is strange on first call in edge, after i did the call to software2.virtualmin.com it was there then ok on https://software.virtualmin.com to

should be ok till 31-12-2021 for

DNS-Name=software.virtualmin.com
DNS-Name=software2.virtualmin.com

IF online test on port 443:
https://en.internet.nl/site/software.virtualmin.com/1376815/#control-panel-21

Don’t know or that/this matter port 443 when do install.sh:

Trust chain of certificateclose

Verdict:

The trust chain of your website certificate is not complete and/or not signed by a trusted root certificate authority.

Technical details:

Web server IP address Untrusted certificate chain
163.172.162.254 software2.virtualmin.com
… R3
… ISRG Root X1

Test explanation:

We check if we are able to build a valid chain of trust for your website certificate.

1 Like

First of all, I want to apologize for being stupid and not really taking notice of the supported OS. I can see that Virtualmin no longer supports Debian 9. Thanks to my hosting customer service “Not Contabo” another provider “Alexhost”. advice me to check on a supported OS. “They already knew about this” LOL

So I installed Debian 10 and the SSL issue popup, I followed what joe mentioned in his post.

@jotst

https://forum.virtualmin.com/t/can-not-install-virtualmin-from-download-page/112459`

Found this post and on this @Joe mentioned that I need to do an update

So I did
apt update && apt upgrade

Boom I was able to run the installation without the error.

Now will wait and see if I get success result

1 Like

Ok nice.

Then it was old OS (openssl…) and the LETSENCRYPT after 30 September not valid problem combi i guess.
As on Bold above writen on a reaction from me guessed… for that expired part

1 Like

@jotst

I got the same error “Configuring Net” I contacted the support and they are going help me install Virtualmin on Centos 7 but not Debian 10 :grinning_face_with_smiling_eyes:

Okay that all being said it took them 1hr+ and still Virtualmin is not ready and when I asked them they replied: “Still in progress.”

Not possible cuz installation won’t take 1hrs+ :rofl: they are going through the same issue that I went through and now they are troubleshooting, trying to fix their servers. :face_with_hand_over_mouth:

So I’m going to assume this is a server-side issue and not a Virtualmin.

Apologize for all the mixup. sometimes you need to hustle to find out what is really going on. :grinning: :v:

Not gonna bang my head on this :sunglasses:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.