comodo certificate

Hi
I have bought a certificate from Namecheap, comodo positivessl.

the domain I installed it under is the same as the FQDN.
http://izidomain.com is the virtual server and
https://sv01.izidomain.com is the FQDN
https://sv01.izidomain.com:10000 is webmin

I copied the ssl.cert to webmin and usermin through virtualmins interface.

None of the browsers accept the certificate although I see Comodo in the options/advanced menu of for instance Firefox.

I also installed the ca.bundle as per description of the install guide.

Why would it not be working?

Hi Ronald,

Well, the name “sv01.izidomain.com” doesn’t resolve for me.

The name “izidomain.com” does resolve though – but when I go to “https://izidomain.com”, it says that the certificate belongs to “secure.lixium.fr”.

I’m not quite sure if that’s the issue you’re running into or not though!

-Eric

hi eric
yes the actual domain is izicompany.com, sorry.
in the meantime i have deleted that virtual server and made the domain an alias to its .nl variable.
Under Ubuntu/firefox it seems to work now, however I have not tested this yet with the IE/FF under windoze

It seemed to have had a conflict somehow when the domain was a virtual server also and having the certificate copied to webmin and usermin. The sub-domain sv01 didn’t exist, though only as hostname.

the odd thing though, the certificate is for the sv01.izicompany.com and that is where I connect to. Then the warning showed saying the certificate is for sv01.izicompany.com. Makes any sense? Not to me…

so under ubuntu with firefox the cert is working as expected.
Under widows with FF and IE8 it is not working.
The error says the cert is not coming from a recognised authority (which is bull cause it is Comodo)

Hey Ronald,

Hrm, are you sure the page wasn’t cached when you tried it on Windows?

I tried it on Windows XP with IE7, and it worked just fine.

It also worked well on Ubuntu, but you knew that :wink:

-Eric

ah I didn’t think about the cached pages. Ill give it a go later on. thanks for the tip.