Command line says BIND is running, but Virtualmin doesn't agree

I commissioned a new CentOS box the other day through a commercial hosting provider. Nothing has been installed yet except Virtualmin.

After installation, upon first login, when Virtualmin was running me through the post-install Wizard, it threw an error telling me that the server hostname did not resolve back to the IP address. The only way I could continue with the post-install wizard was to check the box that said “Don’t do the resolving check”.

At the end of the post-install wizard, not surprisingly I guess, BIND would not start.

I got on to my provider, and got them to create the appropriate DNS A record so that the hostname resolved back to the box (seems shonky that this wasn’t already done). The server can now see that DNS record (I can ping the hostname and it works, which I assume means it can see the hostname resolving back to itself).

However, BIND will still not start. Oddly, when I run “service named start” at the command line, I just get “OK”. By this method I can start, stop and restart with no errors.

But the Virtualmin status screen shows BIND as down, and when I go through Webmin to the BIND module, it shows “Start Bind” and when I click that, nothing happens - well, the screen refreshes but it still says “Start Bind”, indicating that it’s not running.

Anyone got any ideas?

Thanks in advance

Adam

Howdy,

Yeah, there’s a bug regarding all this, it’s due to BIND and chroot:

http://www.virtualmin.com/node/20420

What I would suggest is to disable chroot at Webmin -> Servers -> BIND DNS Server -> Module Config.

However, there should be a new Webmin version coming out soon to resolve all that.

-Eric

Thanks Eric. So that I understand what I’m doing, I wonder if you’d mind briefly explaining what chroot is and what it does?

It’s a security measure… It stands for “change root (directory)” and does exactly that: It causes a process to see a subdirectory of your filesystem as its virtual filesystem root. Thus causing it to see only a limited portion of your actual filesystem, preventing it from traversing into anything it doesn’t strictly need to operate.

Another use is system recovery. If you main system doesn’t boot anymore, you can use e.g. a rescue CD, mount the inoperative filesystem and chroot into it, thus “pretending” that you actually booted from the system, at least in terms of what the processes see as “/”.

Details: http://en.wikipedia.org/wiki/Chroot

Cheers Locutus. Have read around a bit I realise how much there was to that question, and I really appreciate your attempt to summarise things.

For anyone finding this thread in the future, Eric’s suggestion (disabling chroot through Webmin) did indeed allow Bind to launch.