Cluster Slave Server - NAT Settings

Operating system: Ubuntu
OS version: 20.04

Hello everyone.

What is my structure like:

  • 1x Virtualmin DNS Master (internal with NAT-IP)
  • 3x Webmin DNS Slave (external fixed IP)

In the settings of Virtualmin it is possible to use the DNS records with the NAT-IP.

However, when I set up the Cluster Slave Server, the IP address is required by the master. IP from the current host name or by hand.

“Default master server IP for remote slave zones”

If the IP of Virtualmin changes, updates are no longer performed on the slave DNS servers because the old “Master Server IP” exists on the slave DNS server.

Excuse me for my bad English. Use a translator.

Hello @muehlich86 and welcome to the community.

I can see why there will be a problem if the private IP of your DNS master keeps changing. Does your router not permit you to bind a private IP address to the Mac address of the DNS master. If you manage to do that, the private IP address will remain constant and updates can be carried out normally.

Hello @calport

My system works perfectly in the whole but I lack an option.

Virtualmin Settings > Addresses and Networks

Missing exactly this function:

Right here:

Or the functions can be used as here:

Here as an additional selection:

  • IP address of hostname
  • Automatically detect external address
  • Empty field

Then not only are all DNS addresses changed correctly (this works), but the DNS slave servers get the new master IP and accept the transfer.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.