Cluster - Move virtualserver from one Server to another?

System Information
System Hostname: (
Betriebssystem: Ubuntu Linux 20.04.4
Systemzeit: Samstag, 2. Juli 2022 11:48
Kernel und Prozessor: Linux 5.4.0-121-generic auf x86_64
Prozessorinformation: AMD EPYC Processor, 3 Kerne
System-Betriebszeit: 2 Tage, 17 Stunden, 58 Minuten
Laufende Prozesse: 542
Durchschnittliche Prozessor-Auslastung: 0.04 (1 Min) 0.11 (5 Min) 0.09 (15 Min)
Hauptspeicher: 2.67 GiB benutzt / 859.83 MiB zwischengespeichert / 3.74 GiB gesamt
Festplatten Speicher: 40.74 GiB genutzt / 34.22 GiB frei / 74.97 GiB gesamt
Paket-Updates: Alle installierten Pakete sind auf dem aktuellesten Stand

Software Versions
Webmin-Version: 1.995
Usermin-Version: 1.841
Virtualmin Version: 7.1-1
Authentic theme version: 19.95.2
Python version: 3.8.10
Path to Python: /bin/python3
BIND Version: 9.16
Postfix Version: 3.4.13
Logrotate Version: 3.14.0
PostgreSQL Version: 12.11
ProFTPd Version: 1.36

I wonder if I could create some kind of Webmin / Virtualmin Cluster to connect multiple Webmin/Virtual min installations.

I’ve found that webmin may provide that, but I still not see, if it will be possible to move a virtualserver from Virtualmin (Installation 1) to another Virtualmin (Installation2) easily.

What are the easiest way to move VirtualServers and all it’s data and config from one Server to another?

Hi, I just did that 4 times in 1 day, there are few ways you could do this, filesystem backup in webmin, and backup your config files (2 separate steps all done in webmin), and upload it to new server or in my case i used virtualmin backup together with webmin config backup, i used ftp to create backups on my local windows server, but i recommend doing it through webmin filesystem as virtualmin wont have any software or modules you may have installed yourself

Ok, first try with Transfer Virtual Server didn’t work at least.

Then I’ve tried to do the way you told: Backup Virtual Server.
For this I’ve selected to upload it to external Webmin, and provide the root-credentials.

In the logs of the Backup, I can read, that everything should work smooth, at it notes, that the transfer to the destination server was finished successfully.
But I can’t find the uploaded backup-file anywhere at the new server.
Any Idea where it will be placed?

Also a bit strange… it tells me that the size is > 7GB, but should be uploaded in 30 seconds??!

not sure where it is by default, did you search for your backup.tar.gz file on the other server ? check the folders within /etc/webmin directory im guessing should be there
as i mentioned i use third party server dedicated only for my webmin/virtualmin backups and i simply upload it from there just in case something goes wrong

Ok, found it.
/etc is not the right place, because thats are only for config files.
I’ve searched the Server with ncdu and found it at /usr/share/webmin/webmin/

1 Like

@Sinisha82 ok, nice, restore in that way work like a charm.
Even the IP-Address in the DNS setting where replaced by the new ones. Very nice.
Thank you.

1 Like

Nicely done mate!


When you say “Transfer” didn’t work, can you elaborate in terms of what error you received or what part of it didn’t work for you?

I found that it in first step even don’t work with the second variante.
The issue was, that there where still a user with the same name at the new Server.

Even if the log tells me, he try to reset this user and go on, it doesn’t work for both variants.
After I removed the Username, it works (partially) for the second variant.

I didn’t tried the first variant again, because it has a huge downside in my opinion: You can’t choose the SSH-Port of the Target-System. As I do change it for all my servers, I have to reconfigure the target-server back to port 22, to PermitRoot-Login and PermitPassword-Usage.
That’s such a huge downside in my opinion, that I better go with the Export-Import variant.

Means I do have an Apache / Nginx installation. And the Nginx-Config-Files are not placed to the new server. So the transfered VM didn’t fully work at least.


In the hostname field you should be able to specify the port.


Ok, maybe I’ll try this later on. Would be great if you could add a hint on that field, that this is possible.
Would be good to be able to use it that way.

But what if you only allow Private-Key authentication on external Webmin-Server?
Could we not have something like the “Webmin Server” Option in VM-backups for the “Target-Section”?


Good suggestion I’ll pass this onto @Ilia who manages the theme. Cheers

1 Like

Thanks, Peter.

Which page of UI particularly in question?


The page in question where the “hint” would make sense in this case is:

Server Configuration > Transfer Virtual Server

Which if I recall in a thread from a few years back, the “hostname of destination system” field can include a port number.


Ah, okay. We can add a placeholder for input field:

Though, are there other parts of UI where it could also be added?

I would vote for anywhere SSH is used to make something happen. That would include the transfers and import panels, but there may be others. I do a lot of this stuff from the shell so probably there are functionality panels I don’t know about that use SSH.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.